Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 49989 - add action Expand All to the root node of search results
add action Expand All to the root node of search results
Status: RESOLVED WORKSFORME
Product: utilities
Classification: Unclassified
Component: Search
4.x
All All
: P3 with 2 votes (vote)
: 7.2
Assigned To: Jaroslav Havlin
issues@utilities
: UI
: 126125 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-06 10:19 UTC by Marian Petras
Modified: 2012-10-22 13:50 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments
the patch (3.68 KB, patch)
2004-10-06 10:20 UTC, Marian Petras
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Petras 2004-10-06 10:19:27 UTC
This patch adds action Expand All to the root node
of search results (in the Search Results window).

The action expands all the nodes currently
displayed in the Search Results window.

The action is enabled if and only if there is at
least one node below the root node.
Comment 1 Marian Petras 2004-10-06 10:20:06 UTC
Created attachment 18074 [details]
the patch
Comment 2 Marian Petras 2004-10-09 10:52:05 UTC
This enhancement will not be added to NetBeans 4.0 due to performance
reasons. Expanding large number of nodes at a moment could lead to
huge memory consumption and possibly to OutOfMemoryError.
Comment 3 Marian Petras 2004-10-18 16:59:10 UTC
I suggest that the action would have a limit for number of expanded
nodes. So if there was no node expanded, the action would expand the
first <limit> nodes. If there were <n> nodes expanded, the action
would expand the first (<limit>-<n>) collapsed nodes.

I suggest that the limit would be something between 20 and 100.
Comment 4 Marian Petras 2005-05-03 15:17:18 UTC
Accepted.
Comment 5 Alexei Mokeev 2009-04-07 10:27:15 UTC
*** Issue 126125 has been marked as a duplicate of this issue. ***
Comment 6 Jaroslav Havlin 2012-10-22 13:50:58 UTC
There is "Expand All" button in Search Results window in NetBeans 7.2 and newer.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo