Bug 49316 - VCS Output window does not take focus
VCS Output window does not take focus
Status: RESOLVED FIXED
Product: obsolete
Classification: Unclassified
Component: vcscore
4.x
PC Linux
: P4 (vote)
: 4.x
Assigned To: _ pkuzel
issues@obsolete
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-20 21:46 UTC by Jesse Glick
Modified: 2005-02-10 10:25 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2004-09-20 21:46:34 UTC
040920 custom (but for a long time), JDK 1.5,
Ocean. I have the VCS Output window at the bottom
of my screen in sliding mode. If I run a CVS
command like Add from the Editor window, using KB
accelerators for the menu, the VCS Output window
pops up as expected, selected, and shows the
output. But the Editor keeps the KB focus and the
caret continues to blink. Pressing Escape does not
close the VCS Output window; I need to use Ctrl-0.
Comment 1 Richard Gregor 2004-09-22 14:29:27 UTC
I can't reproduce this with fresh build 040922. Signing as works for me.
Comment 2 Jesse Glick 2004-10-11 20:00:55 UTC
Can't reproduce either, but only because of issue #50244, which is
rather worse.
Comment 3 Jesse Glick 2004-10-13 22:11:04 UTC
After working around #50244 (by deleting old Windows2Local config
stuff), I can see this problem again.
Comment 4 _ pkuzel 2005-01-12 16:58:23 UTC
BTW I like this behaviour.
Comment 5 Jesse Glick 2005-01-13 01:32:20 UTC
It is never correct for the editor to become unselected yet retain
focus. It is OK to not select the VCS Output window, or to select it,
or to attempt to display it without selecting it (if it is not in
autohide mode), but not this mixture.
Comment 6 Martin Entlicher 2005-02-10 10:25:20 UTC
It seems to be fixed by Petr together with issue #54284.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo