Bug 49315 - Focus remains in Find Usages window even after jumping to source
Focus remains in Find Usages window even after jumping to source
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Refactoring
4.x
PC Linux
: P4 (vote)
: 4.x
Assigned To: issues@java
issues@java
: FOCUS
: 56033 (view as bug list)
Depends on:
Blocks: 51153
  Show dependency treegraph
 
Reported: 2004-09-20 21:19 UTC by Jesse Glick
Modified: 2005-04-09 00:27 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot (71.77 KB, image/png)
2004-09-20 21:22 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2004-09-20 21:19:42 UTC
040920 custom, JDK 1.5, Ocean. Searched for usages
of a method. Used KB navigation to select one
usage (*), and pressed Enter. Editor correctly
opened file with that usage, and displayed it
selected, but there was no caret in the editor;
focus remained on the F.U. window, as indicated by
focus marking. See screenshot.

(*) - By the way, when you give focus to the
Refactoring window, the initial KB focus is not in
the tree of hits. You have to press TAB three
times to put it there. This is annoying and should
be corrected as well.
Comment 1 Jesse Glick 2004-09-20 21:22:11 UTC
Created attachment 17774 [details]
Screenshot
Comment 2 Jan Becicka 2005-01-19 10:52:35 UTC
The first part of this issue is already fixed.
"by-the-way" part is still valid and unfortunately I don't know where
is the KB focus. I tried to call requestFocus(),
requestFocusInWindow(). But refactoring window still does get KB
focus. It is strange.
Comment 3 Jesse Glick 2005-01-22 21:41:53 UTC
You perhaps need to override requestFocusInWindow (?) to set focus to
the tree. I'm not sure of details but look at e.g. Projects tab impl
to get the idea.
Comment 4 Jan Becicka 2005-02-18 09:58:52 UTC
I tried everything including overriding requestFocusInWindow().
I give up fixing this bug. I'm always lost in this focus stuff.
Comment 5 Jan Becicka 2005-03-14 07:26:16 UTC
*** Issue 56033 has been marked as a duplicate of this issue. ***
Comment 6 Jan Becicka 2005-03-23 12:33:21 UTC
Checking in org/netbeans/modules/refactoring/ui/RefactoringPanel.java;
/cvs/refactoring/src/org/netbeans/modules/refactoring/ui/RefactoringPanel.java,v
 <--  RefactoringPanel.java
new revision: 1.49; previous revision: 1.48
done
Checking in org/netbeans/modules/refactoring/ui/RefactoringPanelContainer.java;
/cvs/refactoring/src/org/netbeans/modules/refactoring/ui/RefactoringPanelContainer.java,v
 <--  RefactoringPanelContainer.java
new revision: 1.16; previous revision: 1.15
done


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo