Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 48890 - Tomcat fails to release locks on WEB-INF/lib
Tomcat fails to release locks on WEB-INF/lib
Status: RESOLVED DUPLICATE of bug 47919
Product: serverplugins
Classification: Unclassified
Component: Tomcat
4.x
PC Windows XP
: P3 (vote)
: 4.x
Assigned To: Sherold Dev
issues@serverplugins
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-11 22:10 UTC by _ gtzabari
Modified: 2006-06-05 00:51 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ gtzabari 2004-09-11 22:10:24 UTC
dev build 200409091800
J2SE 1.5 RC

I hit SHIFT-F11 to rebuild my web project. It
happens to have ant*.jar in the WEB-INF/lib
directory. I get an error removing the file
because it is locked. I am guessing the tomcat
server has it locked?
Comment 1 _ gtzabari 2004-09-12 07:24:09 UTC
${dist.dir} is locked too for some reason... It is likely this is a
Netbeans quirk (i.e. it locks it upon starting up) because if I
restart Netbeans it *still* claims the file is locked and if I close
Netbeans I can delete the file from windows directly.
Comment 2 Petr Jiricka 2004-09-13 09:56:12 UTC
I can not reproduce the problem with ${dist.dir}
Comment 3 Pavel Buzek 2004-09-25 01:01:05 UTC
Gili, is it really ${dist.dir}? I would expect ${build.web.dir} or its
subdir WEB-INF\lib to cause problems but ${dist.dir} only contains
.war file which is not used for deployment.

Stepane, is not this a duplicate of the following bug?

http://www.netbeans.org/issues/show_bug.cgi?id=47919
Project Clean and Build can't delete jar file because it is in use.
Comment 4 Sherold Dev 2004-09-27 10:30:15 UTC
Yes, it seems so. Marking as duplicate of issue 47919.

*** This issue has been marked as a duplicate of 47919 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo