Bug 48665 - Webservice isn't deployed to AppServer
Webservice isn't deployed to AppServer
Status: CLOSED INVALID
Product: webservices
Classification: Unclassified
Component: Code
4.x
Sun SunOS
: P1 (vote)
: TBD
Assigned To: _ ludo
j2eetmp
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-08 13:07 UTC by Petr Blaha
Modified: 2004-10-15 09:31 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
testing web project with web service (40.05 KB, text/plain)
2004-09-08 15:19 UTC, Petr Blaha
Details
testing web project with web service (40.05 KB, application/octet-stream)
2004-09-08 15:19 UTC, Petr Blaha
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Blaha 2004-09-08 13:07:25 UTC
Build: 040908
App Server 8.1 PE build b27-beta
Steps to reproduce, see Ludo's NetBeans J2EE
Support EA1 intial Cookbook:
1) create new web module
2) add new web service
3) set new web service endpoint
4) deploy module to server
5) run in browser
http://localhost:8080/context_path/end_point
Server responses HTTP 404, resource unavalaible. I
think the webservice isn't deployed to server
Comment 1 _ ludo 2004-09-08 15:03:57 UTC
Well, it worked for the cookbook, so we need much more detail...
Platform,name of the web service, maybe the zip file for this app.
Did you add an operation to the web service?
Might be the issue?
Did you see wscompile step in the build output.

Bugs well described will take much faster to reproduce and correct.
Comment 2 Petr Blaha 2004-09-08 15:19:20 UTC
Created attachment 17488 [details]
testing web project with web service
Comment 3 Petr Blaha 2004-09-08 15:19:29 UTC
Created attachment 17489 [details]
testing web project with web service
Comment 4 Petr Blaha 2004-09-08 15:23:25 UTC
I preformed these steps:
1) create new web module
2) add new web service
3) add one method to interface and to class
4) set endpoint
5) run project
No error messages were on Output tab. I thought, that all is OK.
Comment 5 _ ludo 2004-09-08 15:36:43 UTC
one simple question: what is the target server: it is Tomcat or App
server 8.1?
See the runtime tab default server, as well as one of the properties
of the Web App it self...


Tomcat will not work since it does not contain the necessary Web
Services runtime.
Comment 6 _ ludo 2004-09-08 15:42:43 UTC
I tried this app.
The sun specific DD data is incorrect:
in the sun-web.xml I see

    <webservice-endpoint>
      <port-component-name>mojo</port-component-name>
      <endpoint-address-uri>mojo</endpoint-address-uri>

it should be Hello, like:


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE sun-web-app PUBLIC "-//Sun Microsystems, Inc.//DTD
Application Server 8.0 Servlet 2.4//EN"
"http://www.sun.com/software/appserver/dtds/sun-web-app_2_4-0.dtd">
<sun-web-app>
  <context-root>/WsHello</context-root>
  <servlet>
    <servlet-name>WSServlet_Hello</servlet-name>
    <webservice-endpoint>
      <port-component-name>Hello</port-component-name>
      <endpoint-address-uri>Hello</endpoint-address-uri>
      <transport-guarantee/>
    </webservice-endpoint>

There is a deployment failure (error reporting is ugly, see it in the
App server log file.

As said in the cook book, these 2 values will be generated fo you soon.
For now, you need to enter the name of the WebService, not a random
name like mojo.

The whole deploy error reporting needs improvement, I admit that.

Let us know after the name change, you can deploy the service and see
its wsdl via the borwser.
Comment 7 Petr Blaha 2004-09-08 16:17:43 UTC
It's working for me now. I didn't read your cook book carefully. This
isn't bug, close issue as invalid. I agree, we need better error
reporting.
Comment 8 _ ludo 2004-09-08 16:21:00 UTC
but... we need to be much better in error reporting.
This will become a series of bugs spwaned between:
Netbeans J2EEserver module
App Server plugins
and
App Server runtimes...
EA2 I guess, except for AS runtime: 8.1 is now in Beta, and bugs
should be filed quickly if we want them to be considered in FCS.
Comment 9 Petr Blaha 2004-10-13 10:39:50 UTC
Remove all issues from temporary component.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo