Bug 48441 - Can't run IDE if JDK is in directory with space
Can't run IDE if JDK is in directory with space
Status: CLOSED FIXED
Product: platform
Classification: Unclassified
Component: -- Other --
4.x
PC Windows XP
: P1 (vote)
: 4.x
Assigned To: _ ttran
issues@platform
: SPACE_IN_PATH
: 48457 48483 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-03 09:59 UTC by zikmund
Modified: 2008-12-22 18:00 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zikmund 2004-09-03 09:59:06 UTC
Build 200409022120, Windows (XP)

1) Have JDK (1.5/1.4) installed in directory with
a space (e.g. default 1.5 directory in 'Program
Files')
2) Run nb.exe
3) ERROR:
Exception in thread "main"
java.lang.NoClassDefFoundError:
Files\Java\jdk1/5/0\jre\bin\java/exe
Comment 1 Marian Mirilovic 2004-09-03 10:01:08 UTC
Trung,
maybe related to fix for issue 48378.
Comment 2 _ ttran 2004-09-03 10:35:57 UTC
this is quite likely, I'll look at it
Comment 3 Marian Mirilovic 2004-09-03 14:18:06 UTC
*** Issue 48457 has been marked as a duplicate of this issue. ***
Comment 4 cezariusz 2004-09-03 14:23:37 UTC
Any workaround except reverting to an older version?
Comment 5 _ ttran 2004-09-03 14:36:28 UTC
either install JDK into a dir without space in path, or wait for the
next nightly build
Comment 6 _ ttran 2004-09-03 16:52:59 UTC
fixed
Comment 7 _ ttran 2004-09-05 13:03:50 UTC
*** Issue 48483 has been marked as a duplicate of this issue. ***
Comment 8 zikmund 2004-09-07 10:37:22 UTC
Verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo