Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 48296 - [60cat] Add javadoc when using encapsulate
[60cat] Add javadoc when using encapsulate
Status: CLOSED FIXED
Product: editor
Classification: Unclassified
Component: Refactoring
5.x
All All
: P3 with 1 vote (vote)
: 6.x
Assigned To: Jan Pokorsky
issues@java
:
: 53148 61422 71777 (view as bug list)
Depends on:
Blocks: 73477
  Show dependency treegraph
 
Reported: 2004-09-01 12:30 UTC by cezariusz
Modified: 2015-03-27 07:44 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cezariusz 2004-09-01 12:30:57 UTC
Old RefactorIT was adding a javadoc template do 
getters and setters created using encapsulate. 
It would be nice if the built-in refactoring 
were also adding simple javadoc comments to them.
Comment 1 cezariusz 2004-09-21 10:11:54 UTC
Any comments from the refactoring team?
Comment 2 Jan Becicka 2004-09-21 10:16:12 UTC
Yes, this is reasonable enhancement :)
Comment 3 cezariusz 2004-09-21 10:32:05 UTC
Cool, thanks Jan ;)

So, it there a chance to be included in 4.0?
Comment 4 Martin Matula 2004-11-09 19:03:26 UTC
If we want to address this, we need a UI spec. Reassigning to Dusan. 
I guess a new setting somewhere (in Options window) will be 
necessary so that users can customize the javadoc.
Hopefully we will be able to add this in promoF (nb4.2).
Comment 5 Jan Becicka 2005-05-20 09:49:13 UTC
*** Issue 53148 has been marked as a duplicate of this issue. ***
Comment 6 Jan Becicka 2005-08-25 10:13:54 UTC
*** Issue 61422 has been marked as a duplicate of this issue. ***
Comment 7 valeredejardin 2006-11-22 14:32:52 UTC
What does "future" means please? It seems too unclear to me. Is NB6 "future"? I
guess no from the target milestone dropdown list :-(
Comment 8 Jan Becicka 2006-11-23 12:22:41 UTC
Old target milestone was 5.0 - which was wrong. So I changed it to future, which
means, that it is not yet clear which release will include this enhancement.
Comment 9 Karthikeyan Rajeswaran 2007-11-05 18:58:15 UTC
A similar request has been made at:
http://www.netbeans.org/servlets/ReadMsg?list=nbusers&msgNo=102892

According to on-line help (Topic: Generating Getter and Setter Methods) :
   You can generate getter and setter methods for a field in one of the following two ways:
   By using the code completion box...
   By using the Encapsulate Field refactoring command...

Since this issue (48296) deals with the 'encapsulate method', perhaps it will also handle the other method of using
'code completion'. If not, please inform and a separate RFE can be created for code completion method and the two issues
linked via URLs in description.
Comment 10 Jan Pokorsky 2008-04-28 17:16:44 UTC
*** Issue 71777 has been marked as a duplicate of this issue. ***
Comment 11 Jan Pokorsky 2008-04-28 17:32:13 UTC
I am working on this.
Comment 12 Jan Pokorsky 2008-04-28 18:17:47 UTC
krajeswaran: Create Getter Setter is something else. It does none refactoring.

implemented as http://hg.netbeans.org/main/rev/ab2b7b02a475
Comment 13 gglazer 2008-04-28 18:34:57 UTC
If I understand the previous comment correctly, you are closing the issue because the implementation area is not
relevant to the requested change.  This is not acceptable.  This RFE seeks to have JavaDoc automatically inserted when
getters and setters are created.  How that is implemented should be opaque to the issue status.  On casual inspection,
the changes at http://hg.netbeans.org/main/rev/ab2b7b02a475 do not appear to satisfy the requirements of this issue,
therefore I am reopening it.
Comment 14 Jan Pokorsky 2008-04-28 18:55:16 UTC
Please read the issue's summary. The issue is about 'Add javadoc when using encapsulate'. The Encapsulate refactoring UI
provides possibility to add comments for generated methods now. I whould say it is fixed.
Comment 15 Quality Engineering 2008-04-29 04:18:20 UTC
Integrated into 'main-golden', available in NB_Trunk_Production #164 build
Changeset: http://hg.netbeans.org/main/rev/ab2b7b02a475
User: Jan Pokorsky <jpokorsky@netbeans.org>
Log: #79042: Encapsulate Fields enhancements
  * select buttons #118849
  * insert point
  * sort by
  * comments #48296, #73477
  * setters for final fields
  * new layout
Comment 16 cezariusz 2015-03-27 07:44:49 UTC
Verified and closed.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo