Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 47508 - [40cat] Freeform Project: No way in GUI to associate F9 with a compile target
[40cat] Freeform Project: No way in GUI to associate F9 with a compile target
Status: RESOLVED DUPLICATE of bug 46886
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
4.x
PC Windows ME/2000
: P2 (vote)
: 4.x
Assigned To: Jesse Glick
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-19 18:53 UTC by shemnon
Modified: 2005-12-22 18:31 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description shemnon 2004-08-19 18:53:01 UTC
[ BUILD # : 200408121535 ]
[ JDK VERSION : J2SE 1.4.2_04 ]

As best as I can tell there is no way to associated the F9 key with any ant task to compile a particular file.  A major ergonimic negative with it comes to the free form project.

My recommendation is to add another line in th ebould and run properties page and wizard page labeled "compile" that will be run when buid->compile file is selected or "F9" is pressed.  This would use the project for the file that the focused file is in.
Comment 1 Jesse Glick 2004-08-19 20:11:45 UTC
No plans to put this in the GUI, at least not for 4.0. (The property
dialog for freeform projects might be expanded in future releases; the
main constraints are time to implement and test, since GUIs are much
slower and buggier to write; and the risk of bloating the GUI to the
point that simple and common things are hard to find with all the noise.)

However you can already bind this action ("compile.single") in the
project.xml; you need to specify an Ant property which will hold the
name of the file(s) to be compiled.

A guide for advanced customization of freeform projects is planned but
it is not available yet. You can get an idea of the possibilities with
these links:

http://www.netbeans.org/source/browse/performance/threaddemo/
http://www.netbeans.org/source/browse/ant/freeform/eg/simple/
Comment 2 shemnon 2004-08-19 21:24:47 UTC
What we absolutely need then is a document listing all of these "magic
names" and what pieces of the UI they match up to.
Comment 3 Jesse Glick 2004-08-20 17:41:22 UTC
Of course. As I said, it is under development. John Jullion is
preparing it I believe.
Comment 4 Marian Mirilovic 2005-12-22 14:31:30 UTC
very old issue resolved a long time ago, closing
Comment 5 shemnon 2005-12-22 15:37:20 UTC
No, this was not fixed a long time ago.  Still in GUI of 5.0 beta2 there is no
way to associate any compile task with the F9 Key.

The bug sin't that there is no way in general, but that there is no support in
the GUI for this.  This is also freform ant (in cast there is a difference)

If netbeans is not going to fix it close it as WONTFIX rather than claiming it
was resolved.
Comment 6 Jesse Glick 2005-12-22 18:31:10 UTC
See issue #46886 for background. As of 4.1 you can just press F9 and the IDE
should offer to generate a target for you and bind it. Also see

http://www.netbeans.org/kb/41/freeform-config.html

*** This issue has been marked as a duplicate of 46886 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo