Bug 47493 - Build Required Projects has different meaning
Build Required Projects has different meaning
Status: CLOSED DUPLICATE of bug 47507
Product: projects
Classification: Unclassified
Component: Generic Projects UI
PC Windows XP
: P4 (vote)
: 4.x
Assigned To: jrojcek
Depends on:
  Show dependency treegraph
Reported: 2004-08-19 16:08 UTC by zikmund
Modified: 2006-03-24 10:21 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT


Note You need to log in before you can comment on or make changes to this bug.
Description zikmund 2004-08-19 16:08:05 UTC
In Java Project "Build Required Projects" checkbox
has different meaning -- it forces building of
projects only on compile classpath (which could be
a subset of required projects).

Model case:
Have java project "App" which has java library
project "DataModel" on its compile classpath.
Have java library project "Utils" which is on
DataModel's compile classpath.
Both libraries are in required projects of App,
but building of Utils depends on DataModel setting
of checkbox "Build Req.Proj." not on the App's one.

It should be probably renamed to something more
appropriate (like "Directly Required Projects"?) .

(build 200408181800)
Comment 1 Jesse Glick 2004-08-19 18:14:42 UTC
True. Jano?
Comment 2 David Konecny 2004-09-06 14:14:04 UTC
This was resolved as part of issue 47507. The checkbox was moved to
compilation panel and renamed to "Build Projects on Classpath".

*** This issue has been marked as a duplicate of 47507 ***
Comment 3 zikmund 2004-09-07 10:32:25 UTC
Fix verified.

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo