Bug 47233 - [65cat] Votes should not be removed
[65cat] Votes should not be removed
Status: RESOLVED INVALID
Product: obsolete
Classification: Unclassified
Component: collabnet
4.x
PC Windows ME/2000
: P1 with 16 votes (vote)
: TBD
Assigned To: support
issues@www
PCN 11587, CNSC-019131, PCN 63985
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-15 08:35 UTC by Peter Nabbefeld
Modified: 2009-11-08 02:33 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Nabbefeld 2004-08-15 08:35:26 UTC
I've got the following message:

"You used to have a vote on issue 47232, but it
has been removed.

Reason: This issue has been moved to a different
component

Votes removed: 1 [...]"

Votes should only be removed, if there are no
votes left in the new category, otherwise voting
does not make much sense.
Comment 1 Unknown 2004-08-19 21:52:50 UTC
Over to Jack for review.
Comment 2 jcatchpoole 2004-08-20 08:46:31 UTC
Sounds like a dup of issue 26513.

*** This issue has been marked as a duplicate of 26513 ***
Comment 3 jcatchpoole 2004-08-26 15:29:18 UTC
My mistake, not a dup; this is specifically about votes moving between
categories.  My apologies epdv.

Collab : this is similar in nature to issue 26513, but a different
type of vote moving.  Will Scarab handle this as expected ?
Comment 4 Unknown 2004-10-28 00:02:19 UTC
CollabNet is seriously considering the voting issue in its future 
CEE architecture(incolving PT). I will accumulate all the voting 
issues and present to our internal team for review.
Comment 5 Unknown 2006-04-07 01:47:42 UTC
Updating SWB.
Comment 6 jcatchpoole 2006-04-11 18:25:18 UTC
*** Issue 72474 has been marked as a duplicate of this issue. ***
Comment 7 Unknown 2006-05-24 23:54:18 UTC
Making this a RESOLVED->REMIND, since this is not considered for IZ yet.
Comment 8 jcatchpoole 2006-06-26 16:39:48 UTC
*** Issue 78997 has been marked as a duplicate of this issue. ***
Comment 9 Unknown 2007-04-18 07:12:10 UTC
Reopening to update with the current status of the issue .
Comment 10 Unknown 2007-04-18 07:12:37 UTC
This issue still exist's in the considered bucket for a future release .
Comment 11 jcatchpoole 2008-08-20 13:22:48 UTC
What is the status of this issue ?  Is it still being tracked ?  Ppl kind enough to file issues for NB are
understandably very annoyed when their votes are so inexplicably ignored/removed.  This is a nasty issue.

Thanks.
Comment 12 Lukas Hasik 2008-08-21 12:40:50 UTC
I'm increasing the priority to P1. This bug doesn't allow users influence the severity of issues. I when their votes get
lost they get even more upset. 

OTOH, the voting system is pretty difficult. I'd like to press a button or a link to give my vote to an issue. However
it deserves separate issue or maybe it is logged in already? 
Comment 13 thompsonwd40 2008-08-21 14:31:21 UTC
Very good decision, moving priority to P1.  This is a very emotional issue for users, and if it is not addressed, it
gives many people the impression that the NetBeans team really does *not* care about user involvement in the process.  A
programmer's decision to remain with NetBeans can be influenced solely on an issue such as this, which has little to do
with the IDE!  We're all human, and this is a human issue.
Comment 14 rbalada 2008-08-21 17:30:40 UTC
I can prepare a patch if I would have got access to Issuezilla src code.
Comment 15 Unknown 2008-08-22 06:54:20 UTC
We are certainly working on this issue with the highest priority. We shall update you ASAP once we have adequate
information regarding this issue as our internal team is working on it. 

Regards,
Harsha
Support Operations.
Comment 16 Unknown 2008-08-22 07:16:27 UTC
Could you please let us know which projects are being affected. It would help us in analyzing the issue specific to
those projects.
 
Regards,
Harsha
Support Operations.
Comment 17 puce 2008-08-22 09:20:56 UTC
Here is another sample I just received yesterday:
"
You used to have a vote on issue 144131, but it has been removed.

Reason: This issue has been moved to a different component

Votes removed: 1

http://www.netbeans.org/issues/show_bug.cgi?id=144131
"
Comment 18 Michel Graciano 2008-08-22 11:15:53 UTC
What do you mean 'projects are being affected'? This issue affects all nb.org issuezilla.
Comment 19 Unknown 2008-08-22 12:40:40 UTC
Jack,

We clearly understand that it is affecting the end-users.Due to single IZ database the dependency is ruling over this
only in NB.

If we are going to provide a fix, it might be done as a patch of CEE 5.2 & can be back-ported till CEE 5.0. However this
will not be possible to be back ported to 3.5.1.

This issue requires HIGH LEVEL decision & this cannot be fixed immediately. Let me discuss with the internal team on the
 feasible decision & will keep you posted on this.

Regards,
Ramya
Support Operations
Comment 20 jcatchpoole 2008-08-25 12:56:59 UTC
Thanks.  Another point to consider is that this issue just celebrated it's 4th birthday.
Comment 21 Unknown 2008-09-08 15:17:34 UTC
Voting works on 3 major categories:

1)Max votes per person - This is the maximum number of votes a person gets for the component.  A person can vote more 
than once in an issue (if allowed by the next setting), but each vote counts against this total.

2)Max votes a person can put in a single issue- This is the maximum number of votes a person can put in a single issue, 
and this number must not cause the total number of votes (above) to be exceeded.

3)Max no. of votes for an issue to move out of unconfirmed state.

Given the current votes for an issue, attempt to move all the votes from the old component to the new component, 
assuming they do not violate either of the first 2 rules.  Any votes that exceed either of them will be discarded.  
Then, based on the number of votes that transferred, mark the issue unconfirmed or confirmed.

The aforesaid is in the planning phase.

Regards,
Ramya
Support Operations
Comment 22 Unknown 2008-09-18 10:33:09 UTC
Jack,

We are working on a patch that would fill all the voting features. This patch would be available in the CEE 5.2.

I will update this ticket when it is successfully tested & verified in release.

Regards,
Ramya
Support Operations
Comment 23 Unknown 2008-09-24 07:25:46 UTC
Jack,

The patch is included as the first patch for CEE 5.2.

However, we would not be able to accommodate this in 3.5.1, so the best feasible  way of imparting this fix to NB, is
only when NB gets upgraded to CEE 5.2.

Regards,
Ramya
Support Operations
Comment 24 _ hong_lin 2008-11-12 18:43:57 UTC
Can the message be changed to something like below as a workaround?

" You used to have a vote on issues xxx, but it has been removed because of issue 47233.
......
Please vote again if you still wish to have it fixed sooner."
Comment 25 Unknown 2008-12-02 12:49:33 UTC
In CEE 5.2 p1, when changing an issues component, all existing votes were automatically removed.  Now there is an option
so that the votes can be preserved.

1-Precondition: Set 'remove votes' - 'ON' under 'Issue organization' section' of 'Edit advanced configuration options
(edit setting)' page under 'configuration
options' page and save settings.

Observations: All the votes are removed when the user changed the component to something else. And the respective votes
received email notification about the removal of votes on the issue.


2-Precondition: Set 'remove votes' - 'OFF' and save the setting under 'Edit advanced configuration options (edit
setting)' page under 'configuration
options' link.

Observed: All the votes count are remaining the same even after changing the component to something else.

Regards,
Ramya
Support Operations
Comment 26 Lukas Hasik 2008-12-20 23:39:20 UTC
is there an estimate/plan when the CEE 5.2 p1 will be applied into the issuezilla that is used at netbeans.org? I cannot
see the Set 'remove votes' options now.
Comment 27 jcatchpoole 2008-12-23 09:59:12 UTC
*** Issue 155963 has been marked as a duplicate of this issue. ***
Comment 28 Unknown 2009-01-23 03:58:39 UTC
It should be applied to the site by end of 2009.
Comment 29 Unknown 2009-01-23 04:00:53 UTC
It should be applied to the site by end of 2009.
Comment 30 Unknown 2009-01-23 05:20:14 UTC
Setting Target milestone
Comment 31 twolf2919 2009-01-27 14:10:06 UTC
It takes a whole year to migrate to the new version?  I guess relative to the amount of time it took for this problem to
be done (what, 7+ years?), one year starts looking pretty good.

Sorry to be sounding so negative, but this problem has been annoying people for such a long time!  People, like me, are
really not voting anymore because of it: I gave up voting for bugs I create or someone else just created - even if I'm
extremely interested in it being fixed - simply because I know that, more often than note, the vote will be lost when
someone at NB puts it in a more appropriate component or sub-component or decides that it's a duplicate of an existing
one.  I wait awhile and, IF I REMEMBER, I eventually vote for it.

NB has put so much effort into trying to determine what features are most used in the IDE (the gesture feedback stuff),
but, as a result of this crazy vote shortcoming, NB is getting a totally skewed notion of what BUGS are important to
developers.
Comment 32 jcatchpoole 2009-01-28 00:08:52 UTC
Thanks for the feedback; you're absolutely right, and we are definitely aware of how nasty this is.  Hopefully we can
work with Collab to make this available soon(er).
Comment 33 fommil 2009-05-17 13:46:53 UTC
+1
Comment 34 puce 2009-10-21 10:36:48 UTC
Why is the resolution of this isse "FIXED"? I just got the following mail twice because an issue has been moved to
another component and then has moved again:

---
You used to have a vote on issue 76970, but it has been removed.

Reason: This issue has been moved to a different component

Votes removed: 1

http://www.netbeans.org/issues/show_bug.cgi?id=76970
---

And there is no comment, which says that it should work now -> reopen
Comment 35 Michel Graciano 2009-10-21 13:41:08 UTC
Well, this was fixed in an specific version of Collab product but was not integrated here and will never be since the all 
structure will be updated this week. So, the new issue tracker, Bugzilla, should get this fixed or will be soon (I hope).
Comment 36 Marian Mirilovic 2009-11-08 02:33:46 UTC
We recently moved out from Collabnet's infrastructure


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo