Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 47160 - Main project action enablement status not changed after changing action bindings in freeform project
Main project action enablement status not changed after changing action bindi...
Status: CLOSED WONTFIX
Product: projects
Classification: Unclassified
Component: Ant Freeform
4.x
All All
: P4 (vote)
: 5.x
Assigned To: Jesse Glick
issues@projects
buildsys-e-cand
: API
: 48783 50499 52879 (view as bug list)
Depends on: 46886 51151
Blocks: 42682
  Show dependency treegraph
 
Reported: 2004-08-12 16:16 UTC by pzajac
Modified: 2006-03-24 09:57 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
exception stacktrace (2.11 KB, text/plain)
2004-08-12 16:36 UTC, pzajac
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pzajac 2004-08-12 16:16:39 UTC
[200408111900]
Create a j2see project from ant. Don't map clean
action to the buildscript clean target. The Clean
action is now disabled in Build main menu. Set
mapping for Clean action, using project properties
panel, to the build script clean target. The
action is then disabled. There exists workaround
how to changed the action status. Switch the main
project to a other. And switch back main project
to the previous.
Comment 1 pzajac 2004-08-12 16:35:32 UTC
The IllegalArgument exception is thrown when the targed doesn't exist
in the ant script. See to the attachment.
Comment 2 pzajac 2004-08-12 16:36:44 UTC
Created attachment 16782 [details]
exception stacktrace
Comment 3 Jesse Glick 2004-08-12 17:07:08 UTC
Freeform, not j2seproject.
Comment 4 Jesse Glick 2004-08-12 17:12:57 UTC
Well there is no way currently to fire a change in the set of actions
supported by a project. No solution for D (would require an API
change). Anyway, as you found, the workaround is straightforward, and
there is no loss of functionality.

Can put in a temporary tweak to make the recovery smoother if you try
to run a disabled command (should then disable the action).
Comment 5 Jesse Glick 2004-08-12 19:43:57 UTC
Minor robustness improvement as mentioned:

committed     Up-To-Date  1.7        
projects/projectui/src/org/netbeans/modules/project/ui/actions/MainProjectAction.java
Comment 6 Jesse Glick 2004-09-28 16:14:25 UTC
*** Issue 48783 has been marked as a duplicate of this issue. ***
Comment 7 Jesse Glick 2004-10-15 19:40:54 UTC
*** Issue 50499 has been marked as a duplicate of this issue. ***
Comment 8 Jesse Glick 2004-12-02 21:05:34 UTC
Note: proposed fix of issue #46886 would render this a P5 (probably)
since standard actions would always be enabled anyway.
Comment 9 David Konecny 2005-01-04 12:46:42 UTC
*** Issue 52879 has been marked as a duplicate of this issue. ***
Comment 10 Jesse Glick 2005-04-21 15:25:51 UTC
Skip it; with issue #46886, it doesn't matter much.
Comment 11 pzajac 2005-05-02 10:50:08 UTC
I agree


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo