Bug 46922 - Explorer inplace-rename doesn't work
Explorer inplace-rename doesn't work
Status: CLOSED FIXED
Product: platform
Classification: Unclassified
Component: Window System
4.x
PC All
: P2 (vote)
: 4.x
Assigned To: Milos Kleint
issues@platform
: FOCUS
: 47050 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-05 09:15 UTC by Petr Nejedly
Modified: 2008-12-22 20:48 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Nejedly 2004-08-05 09:15:21 UTC
Both second-click and F2 switches to editing mode,
but finishes editing immediatelly and loses focus.
Most probably caused by dafe's fix of ctrl-tab
traversal problem.
Comment 1 David Simonek 2004-08-05 16:39:37 UTC
It doesn't lookto be caused by ctrl+tab. I disabled ctrl+tab grabbing
in ShortcutAndKeyEventProcessor and bug was still there. I also tried
to find out if some hostile focus events are not coming in the way,
but I didn't find anything. You'll probably have to patch Swing's
inplace editor code to find out what's going on :-(
Comment 2 Marian Mirilovic 2004-08-05 16:56:42 UTC
I've tried to find out focus ;)

Before F2
*** ShortcutAndMenuKeyEventProcessor: current focus owner =
org.openide.explorer.view.TreeView$ExplorerTree[,0,0,355x727,alignmentX=0.0,alignmentY=0.0,border=,flags=16777576,maximumSize=,minimumSize=,preferredSize=,editable=true,invokesStopCellEditing=false,largeModel=false,rootVisible=false,rowHeight=18,scrollsOnExpand=true,showsRootHandles=true,toggleClickCount=0,visibleRowCount=20]

After F2
*** ShortcutAndMenuKeyEventProcessor: current focus owner = null

Comment 3 _ gtzabari 2004-08-09 21:06:14 UTC
I can reproduce under Windows.
Comment 4 Petr Hrebejk 2004-08-10 14:28:59 UTC
*** Issue 47050 has been marked as a duplicate of this issue. ***
Comment 5 Petr Hrebejk 2004-08-10 14:33:29 UTC
It might be winsys anyway. Couldn't it? So back to Milos

Thanks
Comment 6 Milos Kleint 2004-08-11 14:44:16 UTC
fixed in trunk.
Comment 7 Petr Nejedly 2004-08-11 15:04:08 UTC
Works OK now.
Comment 8 Marian Mirilovic 2004-08-13 12:32:48 UTC
Milos,
it will be nice to have this issue fixed for Beta1, so please merge
fix into QBE200408101800 branch too.

Thanks a lot ;)
Comment 9 Milos Kleint 2004-08-13 13:23:28 UTC
done. merdged to beta1 branch.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo