Bug 46352 - Difficult to get focus into editor after starting IDE
Difficult to get focus into editor after starting IDE
Status: CLOSED FIXED
Product: platform
Classification: Unclassified
Component: Window System
4.x
PC Linux
: P3 (vote)
: 4.x
Assigned To: Milos Kleint
issues@platform
: FOCUS, REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-20 18:27 UTC by Jesse Glick
Modified: 2008-12-22 17:19 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2004-07-20 18:27:01 UTC
040719 but observed for maybe a week now in dev
builds (never before that). The first document I
open in the editor window does not get focus,
although it occupies the full screen (e.g.
Projects tab is not visible). No KB focus for e.g.
arrow keys, and not painted as selected. Clicking
on the editor window does not help; nor does
Ctrl-0. However selecting the Projects tab
(sliding it in), and then pressing Escape to slide
it back out, does focus the editor correctly.

1.5.0 b58; both GTK and Ocean.
Comment 1 Milos Kleint 2004-07-27 08:21:35 UTC
reassigning
Comment 2 Milos Kleint 2004-07-27 14:36:36 UTC
i've removed al older workaround that is no longer necessary, seems to
work for me now reliably on 1.5 b59 and 1.4.2.
Comment 3 Jesse Glick 2004-07-29 16:28:26 UTC
To the contrary, in the last few dev builds the problem continues to
occur for me (1.5.0 b59 + Ocean) and in fact seems to be worse in that
it occurs every time I open a file when the documents area was
previously empty. I have to constantly be pressing Ctrl-1 ESCAPE to
get focus into the editor.
Comment 4 Milos Kleint 2004-08-03 13:03:38 UTC
I believe it's fixed now. (after fixing #44278 and #41681)
I tried multiple times and always got focus to the editor component
Comment 5 Jesse Glick 2004-08-03 20:16:29 UTC
It's still broken in a custom build from today (040803, US time). The
first file I open (Alt-Shift-O) after starting the IDE does get focus.
If I close that and open a new one, it does not get focus, nor do
subsequent ones opened when the documents area is empty.
Comment 6 Milos Kleint 2004-08-04 07:54:41 UTC
confirmed, the Shift-Alt-O opening of the editor was the trick to
reproduce the problem..
Comment 7 Milos Kleint 2004-08-06 07:37:08 UTC
I'm reluctant to claim it's fixed, but at least it works for me now. ;)

the problem was that when closing the editor the winsys tried to
select another mode as active, but couldn't find one. Thus kept the
editor, but later this as causing problems when opening again.


Comment 8 Marian Mirilovic 2005-12-20 15:48:08 UTC
This issue was solved long time ago. Because nobody has reopened it neither
added comments, we are verifying/closing it now. 
If you are still able to reproduce the problem, please reopen. Thanks in advance.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo