Bug 45252 - Deadlock while saving and building a form class
Deadlock while saving and building a form class
Status: RESOLVED DUPLICATE of bug 45975
Product: java
Classification: Unclassified
Component: Unsupported
PC Linux
: P2 (vote)
: 4.x
Assigned To: issues@java
Depends on:
  Show dependency treegraph
Reported: 2004-06-20 19:22 UTC by Jiri Rechtacek
Modified: 2007-09-26 09:14 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT

a stack trace when the deadlock appeared (18.03 KB, text/plain)
2004-06-20 19:23 UTC, Jiri Rechtacek
previous exception before deadlock (19.30 KB, text/plain)
2004-06-20 19:53 UTC, Jiri Rechtacek

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Rechtacek 2004-06-20 19:22:40 UTC
>Log Session: Friday, June 18, 2004 11:39:06 AM CEST
>System Info: 
Product Version       = NetBeans IDE Dev (Build
Operating System      = Linux version 2.4.20-9
running on i386
Java; VM; Vendor      = 1.4.2_04; Java HotSpot(TM)
Client VM 1.4.2_04-b05; Sun Microsystems Inc.
Java Home             =

When I edited f form class, didn't save it and
then invoked Build project action (F11), the
attached deadlock has been appeared. (For my next
using this build I used to Save class and then
invoke Build, it has worked w/o deadlocks more.)
Comment 1 Jiri Rechtacek 2004-06-20 19:23:55 UTC
Created attachment 15861 [details]
a stack trace when the deadlock appeared
Comment 2 Jiri Rechtacek 2004-06-20 19:53:49 UTC
Created attachment 15863 [details]
previous exception before deadlock
Comment 3 Jan Becicka 2004-06-30 07:58:29 UTC
Editor guys, please evaluate. Is it possible, that you didn't end
transaction after an exception was thrown? Anyway, please fix at least
an exception and than reassign this issue back to java.
Comment 4 Martin Roskanin 2004-06-30 09:23:58 UTC
NPE fixed:

 <--  NbCompletionJavaDoc.java
new revision: 1.37; previous revision: 1.36

the exception appears in RP thread. MDR lock seems to be in
editor.completion thread. 
CompletionJavaDoc is not fully rewritten using JMI model (issue
#45717). It uses java source hierarchy. Also it seems there are
several calls to mdr w/o transaction from CompletionJavaDoc.

For now reassigning to java, feel free to reassign back...
Comment 5 Martin Matula 2004-07-16 23:23:19 UTC
I believe this is not a deadlock (the thread with
StringBuffer.expandCapacity does not seem to be really blocked). It
looks more like a long-running completion query on the background
holding a transaction while AWT thread is trying to access it. AWT
thread blocking is a duplicate of issue 45975

*** This issue has been marked as a duplicate of 45975 ***

By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo