Bug 43880 - Startup halts waiting to show some dialog
Startup halts waiting to show some dialog
Status: RESOLVED FIXED
Product: obsolete
Classification: Unclassified
Component: vcsgeneric
4.x
PC Linux
: P1 (vote)
: 4.x
Assigned To: Martin Entlicher
issues@obsolete
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-26 13:46 UTC by Jesse Glick
Modified: 2004-08-13 12:12 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump (12.11 KB, text/plain)
2004-05-26 13:47 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2004-05-26 13:46:34 UTC
Happened to me three times in a row in my user
dir; not otherwise sure how to reproduce. JDK
1.5b51, trunk build.

Thread dump should make it clear. VCS stuff must
not block waiting for a dialog to be shown in the
middle of some random method. (No dialog *is* shown.)
Comment 1 Jesse Glick 2004-05-26 13:47:22 UTC
Created attachment 15209 [details]
Thread dump
Comment 2 Jesse Glick 2004-05-26 13:53:11 UTC
After deleting my $userdir/config/VCSMount/*.xml, IDE starts up OK.
Curiously, my mounts are still there. ??
Comment 3 Martin Entlicher 2004-05-26 14:03:26 UTC
This is a warning that is displayed when a non-existing filesystem
property is to be set from a variable. One FS property was removed
recently. When you have CVS filesystem from an older build, which
stores the whole set of variables, you encounter this problem.

The fix would be to present the dialog from a new thread, since the
DialogDisplayer does not have non-blocking notification.
Comment 4 Martin Entlicher 2004-05-26 14:15:00 UTC
Fixed in trunk:

/cvs/vcsgeneric/src/org/netbeans/modules/vcs/advanced/CommandLineVcsFileSystem.java,v
 <--  CommandLineVcsFileSystem.java
new revision: 1.146; previous revision: 1.145


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo