Bug 43792 - Return focus to NetBeans, editor looses focus
Return focus to NetBeans, editor looses focus
Status: VERIFIED WORKSFORME
Product: platform
Classification: Unclassified
Component: Window System
3.x
PC Windows ME/2000
: P3 (vote)
: 4.x
Assigned To: David Simonek
issues@platform
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-25 11:25 UTC by jgordon
Modified: 2008-12-22 21:52 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jgordon 2004-05-25 11:25:11 UTC
I'm using the editor to edit a .java file.
I use another application and then return to 
NetBeans where now the menus have the focus, not 
the editor.
You have to click inside the editor to get the 
focus back on it to continue typing.
This never use to happen in NetBeans 3.5.
Comment 1 Martin Roskanin 2004-06-07 10:28:43 UTC
Try to run NB using a switch -J-Dnetbeans.debug.editor.caret.focus=true 
Debug messages should appear in console. If focus gained and focus
lost events are not fired properly this will not be editor problem and
issue could be duplicate of issue #43616
Comment 2 Martin Roskanin 2004-07-30 13:42:02 UTC
I am sorry, I didn't notice your sentence "Menus have the focus" =>
openide problem
Reassigning...
Comment 3 Milos Kleint 2004-08-03 13:17:46 UTC
I believe it's another reincarnation of issue #41681 and relative..
Dfe, can you try on Windows, it works for me now in linux.
Comment 4 David Simonek 2004-08-04 15:58:29 UTC
It works for me too here on Win. This also may be duplicate of 46826
if James is using alt+tab to switch between the apps. Anyway, either
this works now or is duplicate of 46826, so I'm closing as works for
me. James please correct me if I'm wrong.
Comment 5 jgordon 2004-08-05 17:06:32 UTC
I've been trying to find an exact reason when/why this happens.
It seems to happen when I use ALT+TAB to another application and then 
use CTRL+C to copy stuff to the clipboard.
When I ALT+TAB back to NB's the cursor is in the menu and not in the 
editor.
Comment 6 Marian Mirilovic 2005-07-12 10:14:36 UTC
closed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo