Bug 43780 - tab badly repainted
tab badly repainted
Status: CLOSED FIXED
Product: platform
Classification: Unclassified
Component: Output Window
4.x
PC Windows XP
: P3 (vote)
: 4.x
Assigned To: _ tboudreau
issues@platform
: UI
: 45588 (view as bug list)
Depends on:
Blocks: 43882
  Show dependency treegraph
 
Reported: 2004-05-25 09:46 UTC by Lukas Hasik
Modified: 2008-12-22 21:50 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (97.39 KB, image/png)
2004-05-25 09:47 UTC, Lukas Hasik
Details
maybe more general problem.... (26.73 KB, image/png)
2004-05-25 18:43 UTC, Lukas Hasik
Details
screenshot (4.62 KB, image/png)
2004-06-02 15:31 UTC, Lukas Hasik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Hasik 2004-05-25 09:46:29 UTC
output2.jar from 05/25

see attached picture, the [x] on tab is in text
Comment 1 Lukas Hasik 2004-05-25 09:47:44 UTC
Created attachment 15110 [details]
screenshot
Comment 2 _ tboudreau 2004-05-25 18:35:43 UTC
Ah.  I have to make sure it never uses getName() on the tab (which won't include a trailing 
" " to make room for the close button).
Comment 3 Lukas Hasik 2004-05-25 18:43:01 UTC
Created attachment 15143 [details]
maybe more general problem....
Comment 4 Lukas Hasik 2004-05-25 18:44:21 UTC
just happend to me w/ Explore from here, maybe it's more generic
problem (in WS ?). Feel free to reassign...
Comment 5 _ tboudreau 2004-05-25 19:10:28 UTC
It's two different problems, with the same symptom - but both of them are mine to fix :-/
Comment 6 Lukas Hasik 2004-05-26 10:53:14 UTC
I've filed the explorer tab problem as issue 43868 to don't forget
about it (me&you)
Comment 7 _ tboudreau 2004-05-28 03:06:26 UTC
Should work correctly now - an extra " " is always appended to the tab name (as the old 
window system did when this was its tabbed pane)

Checking in src/org/netbeans/core/output2/Controller.java;
/cvs/core/output2/src/org/netbeans/core/output2/Controller.java,v  <--  Controller.java
new revision: 1.3; previous revision: 1.2
done
Checking in src/org/netbeans/core/output2/ExtPlainView.java;
/cvs/core/output2/src/org/netbeans/core/output2/ExtPlainView.java,v  <--  
ExtPlainView.java
new revision: 1.3; previous revision: 1.2
done
Processing log script arguments...
More commits to come...
Checking in src/org/netbeans/core/output2/ui/AbstractOutputPane.java;
/cvs/core/output2/src/org/netbeans/core/output2/ui/AbstractOutputPane.java,v  <--  
AbstractOutputPane.java
new revision: 1.3; previous revision: 1.2
done
Checking in src/org/netbeans/core/output2/ui/AbstractOutputWindow.java;
/cvs/core/output2/src/org/netbeans/core/output2/ui/AbstractOutputWindow.java,v  <--  
AbstractOutputWindow.java
new revision: 1.3; previous revision: 1.2
done
Comment 8 Lukas Hasik 2004-06-02 15:31:18 UTC
have to reopen, see attachment, it still oversize in 200406011800
Comment 9 Lukas Hasik 2004-06-02 15:31:58 UTC
Created attachment 15433 [details]
screenshot
Comment 10 Lukas Hasik 2004-06-28 10:58:12 UTC
*** Issue 45588 has been marked as a duplicate of this issue. ***
Comment 11 _ tboudreau 2004-08-17 16:39:31 UTC
Checking in ui/CloseButtonTabbedPane.java;
/cvs/core/output2/src/org/netbeans/core/output2/ui/CloseButtonTabbedPa
ne.java,v  <--  CloseButtonTabbedPane.java
new revision: 1.4; previous revision: 1.3
done
Comment 12 Lukas Hasik 2004-09-02 10:50:52 UTC
seems to be ok now


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo