Bug 43601 - Cannot rename library
Cannot rename library
Status: RESOLVED DUPLICATE of bug 46863
Product: java
Classification: Unclassified
Component: Platform
4.x
All All
: P1 (vote)
: 7.1
Assigned To: Tomas Zezula
issues@java
:
: 44867 (view as bug list)
Depends on:
Blocks: 41535
  Show dependency treegraph
 
Reported: 2004-05-20 10:04 UTC by Milan Kubec
Modified: 2011-08-31 14:10 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Milan Kubec 2004-05-20 10:04:56 UTC
Once library is created user has no chance to
rename it.

Usecase:
Developer downloads library JCommon and creates
library in IDE with name JCommon. Later there is
new version of the library so he downloads it and
want to rename the old one according to its
version to JCommon-0.9.3 and then creates new
library for newly downloaded version.
Comment 1 Jesse Glick 2004-05-20 18:25:30 UTC
Don't think this is intended to be supported currently. May be a UI
problem, since references to that library would not automatically be
updated. Will probably not be supported for D. Delete and add instead.
Comment 2 David Konecny 2004-05-24 13:41:49 UTC
Agreed with Jesse. For promoD display name and library ID are the same
things and therefore display name cannot be renamed. 
Comment 3 zikmund 2004-06-17 11:27:58 UTC
*** Issue 44867 has been marked as a duplicate of this issue. ***
Comment 4 Milan Kubec 2005-03-07 11:10:15 UTC
Seems to me more important than P3.
Comment 5 Tomas Zezula 2011-08-31 14:09:50 UTC
Fixed in NB 7.1
See issue #46863

*** This bug has been marked as a duplicate of bug 46863 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo