Bug 43148 - Explorer gets gray
Explorer gets gray
Status: CLOSED FIXED
Product: platform
Classification: Unclassified
Component: Explorer
4.x
All All
: P2 (vote)
: 4.x
Assigned To: _ tboudreau
issues@platform
:
: 43344 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-12 12:26 UTC by Jaromir Uhrik
Modified: 2008-12-22 18:51 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaromir Uhrik 2004-05-12 12:26:53 UTC
[#200405111800; j2sdk1.4.2_03]
1.Open existing project with at least one form
e.g. JFrame
2.In explorer expand the node of such form
3.Invoke popup menu
4.Select Edit item
Result: Letters in the tree of Explorer gets gray
after this action.
Comment 1 Tomas Pavek 2004-05-14 14:40:41 UTC
Tim - any idea why the explorer could start to be rendered gryy suddenly?
Comment 2 _ tboudreau 2004-05-14 20:05:58 UTC
Yup.  Something disabled the cell renderer (editor toolbar?) and NodeRenderer doesn't 
reset the property when rendering.  Will fix.
Comment 3 Jaromir Uhrik 2004-05-17 10:01:50 UTC
*** Issue 43344 has been marked as a duplicate of this issue. ***
Comment 4 _ tboudreau 2004-06-01 14:09:49 UTC
Fix is to get rid of shared NodeRenderer between all explorer views (the problem predates 
the explorer merge, it's just visible now).
Comment 5 _ tboudreau 2004-06-01 15:03:12 UTC
Fixed + NodeRenderer.sharedInstance() deprecated

Checking in openide-spec-vers.properties;
/cvs/openide/openide-spec-vers.properties,v  <--  openide-spec-vers.properties
new revision: 1.146; previous revision: 1.145
done
Processing log script arguments...
More commits to come...
Checking in api/doc/changes/apichanges.xml;
/cvs/openide/api/doc/changes/apichanges.xml,v  <--  apichanges.xml
new revision: 1.202; previous revision: 1.201
done
Processing log script arguments...
More commits to come...
Checking in src/org/openide/explorer/view/ChoiceView.java;
/cvs/openide/src/org/openide/explorer/view/ChoiceView.java,v  <--  ChoiceView.java
new revision: 1.16; previous revision: 1.15
done
Checking in src/org/openide/explorer/view/IconView.java;
/cvs/openide/src/org/openide/explorer/view/IconView.java,v  <--  IconView.java
new revision: 1.21; previous revision: 1.20
done
Checking in src/org/openide/explorer/view/ListView.java;
/cvs/openide/src/org/openide/explorer/view/ListView.java,v  <--  ListView.java
new revision: 1.79; previous revision: 1.78
done
Checking in src/org/openide/explorer/view/NodeRenderer.java;
/cvs/openide/src/org/openide/explorer/view/NodeRenderer.java,v  <--  
NodeRenderer.java
new revision: 1.33; previous revision: 1.32
done
Checking in src/org/openide/explorer/view/TreeTable.java;
/cvs/openide/src/org/openide/explorer/view/TreeTable.java,v  <--  TreeTable.java
new revision: 1.48; previous revision: 1.47
done
Checking in src/org/openide/explorer/view/TreeView.java;
/cvs/openide/src/org/openide/explorer/view/TreeView.java,v  <--  TreeView.java
new revision: 1.164; previous revision: 1.163
done
Processing log script arguments...
Comment 6 Jaromir Uhrik 2004-08-12 17:00:36 UTC
Verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo