Bug 42465 - No Ant Documentation module on AU server
No Ant Documentation module on AU server
Status: VERIFIED FIXED
Product: updatecenters
Classification: Unclassified
Component: AU Masters
3.x
All All
: P1 with 1 vote (vote)
: 3.x
Assigned To: rnovak
Autoupdate Masters
: REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-26 12:06 UTC by _ mihmax
Modified: 2004-05-14 18:11 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ mihmax 2004-04-26 12:06:08 UTC
I follow the instruction in Online Help, but still
cannot find an Ant Documentation Module in any of
the AutoUpdate Servers !!!

Regression!!!
Comment 1 rhulme 2004-04-28 09:14:15 UTC
Also...when I come to load the ant docs (ant-docs.2.12.nbm) and get 
to the 2nd step
in the update centre wizard - select modules to install - there is 
nothing
listed in the include in Install box so I am unable to continue.
Comment 2 s690716 2004-04-29 02:11:49 UTC
After installation of the final release of Netbeans 3.6, there is no 
Ant (1.6) documentation available. Neither in the modules list 
(options) nor in any of the au centers.
Comment 3 rnovak 2004-04-29 12:49:29 UTC
I'll take care of this.
Comment 4 Jesse Glick 2004-04-29 14:23:44 UTC
I have made a build of the module designed for NetBeans 3.6 and
bundling the Ant 1.6.1 manual, Javadoc, and code completion. It
includes the appropriate license and is signed for the NB AU center
(at least I think it is the right signature - Robert please check it).
It seems to work fine when manually installed in a NetBeans 3.6 build
on Linux, though it has no further QA coverage; would appreciate it if
sometime quickly sanity-checked it on Windows at least.

Download from:

http://ant.netbeans.org/servlets/ProjectDownloadList

file 'ant-docs-release36-040429.nbm'.
Comment 5 rnovak 2004-04-29 16:58:47 UTC
Module ant-docs-release36-040429.nbm was uploaded to the Beta UC 
for Netbeans 3.6
Comment 6 _ mihmax 2004-04-29 19:33:25 UTC
Windows sanity-checked.
Tested: 
1. online help - browsed through ant 1.6.1 manual
2. online help translation
3. javadoc
4. code completion

P.S. Why Beta UC?

==== extract from Online Help, topic Building With Ant -> Installing
Ant Documentation ====

To install the Ant Documentation module:
Choose Tools -> Update Center from the main window.
Select the NetBeans Update Center and click Next.
Select the Ant Documentation module, click the Add button, and click Next.
...

==== / extract ====
Comment 7 Jesse Glick 2004-04-30 00:51:23 UTC
Great, thank you Maxym!

It's on the beta UC just because I don't have time to go through every
step on

  http://qa.netbeans.org/processes/stabe_module_criteria_process.html

to certify it as a stable module. (I'm not even sure what kind of test
suite you would have for a bunch of HTML, though I guess it's possible.)
Comment 8 rhulme 2004-05-06 21:05:36 UTC
The Ant help module installs fine under windows. However it does not 
appear in the netbeans help menu. Presumably it should appear in the 
helpset shortcuts menu like the RMI docs, although I am not sure it 
has changed from 3.5.1
Comment 9 Jesse Glick 2004-05-07 00:01:13 UTC
The Help -> Shortcuts submenu is supposed to be deprecated. As of 3.6,
just open Help -> Contents and you should see "Ant 1.6.1 Manual" as
one item among others. (The RMI module might not have been updated in
this way.)
Comment 10 rhulme 2004-05-07 12:24:28 UTC
The ANT help is not included in the help contents, where as the RMI 
help is. The JProfiler also appears in Help Shortcuts and the Help 
Contents. However the Ant Help is nowhere to be seen...
Comment 11 Jesse Glick 2004-05-09 02:16:48 UTC
rhulme - I don't know what might be wrong in your installation; but if
your problems viewing the Ant Manual are not resolved please (1)
ensure the module is really installed (Tools -> Options -> Modules),
(2) file a separate bug report with complete details to reproduce from
scratch (fresh NB install, fresh user dir) and attach your ide.log
file for investigation, since I am not aware of anyone else having
this kind of problem.
Comment 12 rhulme 2004-05-11 20:40:06 UTC
There is no such path as 

Tools -> Options -> Modules

in my version 3.6 of NetBeans. Should I be looking somewhere else.
Comment 13 Jesse Glick 2004-05-11 20:43:02 UTC
Select Tools menu, Options item, expand until you see Modules, expand
it. Check online help for details.
Comment 14 _ mihmax 2004-05-14 17:40:50 UTC
Since Ant documentation module is on Beta Autoupdate Center, 
etiher:

- doc writers need to change documentation
  (currently .../ant/install-docs.html sounds "Select the NetBeans
Update Center and click Next")

- module needs to be oublished on Stable AU Server

Patrick, John-Jullion, what is your opinion?
Or should I file a separate bug against usersguide module?
Comment 15 Patrick Keegan 2004-05-14 18:02:11 UTC
bug 43293 posted to usersguide
Comment 16 _ mihmax 2004-05-14 18:11:52 UTC
OK, then this is VERIFIED


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo