Bug 42113 - [Win LF] Alt+Tab keeps the focus on the menu-bar
[Win LF] Alt+Tab keeps the focus on the menu-bar
Status: VERIFIED WONTFIX
Product: platform
Classification: Unclassified
Component: Window System
3.x
PC Windows ME/2000
: P3 (vote)
: 4.x
Assigned To: David Simonek
issues@platform
jdk_bug_4841881
: FOCUS
: 42499 104901 118378 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-17 22:15 UTC by kachra
Modified: 2008-12-22 14:42 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kachra 2004-04-17 22:15:40 UTC
When using Alt+Tab to switch from the netBeans IDE
to some other Windows application, the 'File'
menu-item on the menu-bar remains focussed. So if
we are in the middle of a java class in the
editor, and Alt+Tab to another application, and
then Alt+Tab back to the IDE, one has to hit the
'Esc' key before the class editor regains focus
from the menu-bar. This bug is erratic but can be
reproduced more often than not. This is peculiar
to the Windows look-n-feel, as the Metal
look-n-feel works perfectly well.
Comment 1 David Simonek 2004-06-18 14:28:45 UTC
I guess this is Win LF only because in Win LF, pressing Alt key means
start of main menu traversal with keyboard.
Comment 2 David Simonek 2004-06-18 14:30:19 UTC
*** Issue 42499 has been marked as a duplicate of this issue. ***
Comment 3 _ ttran 2004-07-21 09:10:22 UTC
I saw the same bug report and closed it as WONTFIX yesterday.  The
problem lies in the Swing impl of Windows L&F not in NB
Comment 4 David Simonek 2004-08-02 13:45:48 UTC
*** Issue 46826 has been marked as a duplicate of this issue. ***
Comment 5 Marian Mirilovic 2005-07-12 10:02:26 UTC
closed
Comment 6 David Simonek 2007-07-09 15:29:46 UTC
*** Issue 104901 has been marked as a duplicate of this issue. ***
Comment 7 Jiri Prox 2007-10-11 10:54:03 UTC
*** Issue 118378 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo