Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 41955 - [2004-04-30]API Review of HTML renderer integration
[2004-04-30]API Review of HTML renderer integration
Status: CLOSED FIXED
Product: platform
Classification: Unclassified
Component: -- Other --
4.x
All All
: P3 (vote)
: 4.x
Assigned To: _ tboudreau
issues@platform
core-promod
: API_REVIEW_FAST
Depends on:
Blocks: 29466
  Show dependency treegraph
 
Reported: 2004-04-14 14:31 UTC by _ tboudreau
Modified: 2008-12-22 20:26 UTC (History)
2 users (show)

See Also:
Issue Type: TASK
:


Attachments
HtmlRenderer javadoc (38.84 KB, text/html)
2004-04-14 14:43 UTC, _ tboudreau
Details
HtmlRenderer.Renderer javadoc (19.18 KB, text/html)
2004-04-14 14:46 UTC, _ tboudreau
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ tboudreau 2004-04-14 14:31:48 UTC
Please review the API changes planned for integrating the HTML 
renderer.
Comment 1 _ tboudreau 2004-04-14 14:43:42 UTC
Created attachment 14386 [details]
HtmlRenderer javadoc
Comment 2 _ tboudreau 2004-04-14 14:46:13 UTC
Created attachment 14388 [details]
HtmlRenderer.Renderer javadoc
Comment 3 _ tboudreau 2004-04-28 15:39:53 UTC
(Mysterious how this got assigned to issues@core, but apireviews has been on cc the 
whole time anyway and that is who it was originally assigned to).

This issue has been available for fast track review for two weeks with no response.  I will 
assume silence == assent, and integrate the html renderer as planned on Monday, May 3.
Comment 4 Jaroslav Tulach 2004-04-29 06:21:49 UTC
Copied my comment from issue 29466

Why this commit contains code that is "FOR DEMO PURPOSES ONLY!". I do
not like it.

org.openide.awt.HtmlLabelUI was not in original plans or am I wrong?

This should not be in the diff I guess:
+/*
+ * HtmlRenderer.java
+ *
+ * Created on January 2, 2004, 12:49 AM
+ */

Please point me to the list of usecases that justify existence of
HtmlRenderer.Renderer - btw. my desire is to eliminate that interface
so usecase with direct usage of it are not that useful, I am searching
for some higher level interfaces.

Why org.openide.awt.HtmlRendererImpl is public?

There are no tests neither for FilterNode, DataNode vs. HtmlStatus.
Comment 5 _ tboudreau 2004-04-29 09:51:02 UTC
See my response in issue 29466 - let's keep the technical conversation there.
Comment 6 _ tboudreau 2004-05-03 14:49:31 UTC
x
Comment 7 Marian Mirilovic 2005-12-20 15:50:08 UTC
This issue was solved long time ago. Because nobody has reopened it neither
added comments, we are verifying/closing it now. 
If you are still able to reproduce the problem, please reopen. Thanks in advance.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo