Bug 41861 - Suggestions only updated for first editor tab
Suggestions only updated for first editor tab
Status: VERIFIED WORKSFORME
Product: platform
Classification: Unclassified
Component: Window System
3.x
PC Windows XP
: P3 (vote)
: 4.x
Assigned To: mslama
issues@platform
: SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-08 15:41 UTC by _ moser
Modified: 2008-12-23 14:32 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE log file (82.42 KB, text/plain)
2004-04-08 15:43 UTC, _ moser
Details
System folder of my user home directory (1.40 MB, application/x-tar)
2004-04-26 15:20 UTC, _ moser
Details
Thread-dump for dead-locked IDE window (16.32 KB, text/plain)
2004-10-15 11:48 UTC, _ moser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ moser 2004-04-08 15:41:45 UTC
Using the 3.6RC builds as well as earlier dev
build I noticed that the suggestions view is not
updated after switching editor tabs. So I only can
use suggestions once for the very first edited
class. It als produces a lot of exceptions in
ide.log like this:

> [WinSys.PersistenceManager.getTopComponentForID]
Problem when deserializing TopComponent for
tcID:'Errors'. Reason: Top component Errors could
not be located or loaded from Components folder.
> INFORMATIONAL *********** Exception occurred
************ at Fri Apr 02 14:57:03 CEST 2004
> java.io.FileNotFoundException: Top component
Errors could not be located or loaded from
Components folder.
> [catch] at
org.netbeans.core.windows.persistence.PersistenceManager.getTopComponentPersistentForID(PersistenceManager.java:492)
>     at
org.netbeans.core.windows.persistence.PersistenceManager.getTopComponentForID(PersistenceManager.java:570)
>     at ...
>     at
org.netbeans.core.windows.ModeImpl.dockInto(ModeImpl.java:120)
>     at
org.netbeans.modules.tasklist.core.TaskListView.showInMode(TaskListView.java:1024)
>     at
org.netbeans.modules.tasklist.suggestions.ui.SuggestionsAction.show(SuggestionsAction.java:61)
>     at
org.netbeans.modules.tasklist.suggestions.ui.SuggestionsAction.performAction(SuggestionsAction.java:47)
>     at ...

I have attached the complete ide.log.

Neither reopening the suggestions view nor
reopening java source files in editor help.
Unfortunately suggestions so render to be useless.
Comment 1 _ moser 2004-04-08 15:43:04 UTC
Created attachment 14332 [details]
IDE log file
Comment 2 _ moser 2004-04-08 16:14:42 UTC
I checked, as Petr Kuzel proposed, whether it is releated to spaces in
userdir, and yes - it is. Using -userdir "my-user-dir" in bin/ide.cfg
without spaces fixed the problem for me.
Comment 3 _ moser 2004-04-08 18:08:58 UTC
Unfortunately this is not true. Once the suggestion view was hidden
(e.g. by the output tab after compilation), I never get the
suggestions view updated again. The errors are the same as in the
attached ide.log.
Comment 4 _ pkuzel 2004-04-09 12:52:05 UTC
On mailing list you wrote that you got different exception (index one)
after using userdir without spaces. Please fill separete issue for it.

Problem when deserializing TopComponent will be handled by window
system developers.  
Comment 5 _ moser 2004-04-13 13:05:12 UTC
Checking again this issue I found that this definitely has nothing to
do with SPACES. I changed my user home to a folder wothout spaces and
can reproduce the problem very easily: 
a) Open the suggestions view, switch editor tabs - suggestions are
updated correctly.
b) Now modify, save and compile the current editor tab, so that the
output window opens (reporting compilation success) and hides the
suggestions view.
c) Open the suggestions view again, switch editor tabs - suggestions
are  not updated any longer.
Comment 6 _ ttran 2004-04-23 23:11:48 UTC
would be good if you can zip your <userdir>/system dir and attach the
zip file here.  Thanks
Comment 7 _ moser 2004-04-26 15:20:27 UTC
Created attachment 14558 [details]
System folder of my user home directory
Comment 8 mslama 2004-06-10 13:45:40 UTC
Is it still present in current dev build? How to reproduce? Some
steps? How do you get Suggestions?
Comment 9 _ moser 2004-06-10 17:34:47 UTC
Sorry, but I can't tell you so far, because I'm not yet using the
dev-builds. Does this mean that I don't need to expect a patch for
3.6, any longer?
Comment 10 mslama 2004-06-11 08:01:42 UTC
It is too late to fix it in release 3.6. It will be fixed in main
trunk (dev build) if it still happens. If it is very annoying I can
create patch for NB 3.6 which will be available here. Still I need
some way how to reproduce either on dev build or NB 3.6 to be able to
find fix or in other words to find out why this issue happens.

I was not able to find how to view Suggestions component or where is
Suggestions action located. Do I need to get something from AutoUpdate
Center?
Comment 11 _ moser 2004-06-11 10:51:19 UTC
I think you can get it from 
http://www.netbeans.org/updates/dev/36_{$netbeans.autoupdate.version}_{$netbeans.autoupdate.regnum}.xml?{$netbeans.hash.code}
or 
http://www.netbeans.org/updates/alpha/36_{$netbeans.autoupdate.version}_{$netbeans.autoupdate.regnum}.xml?{$netbeans.hash.code}

But I'm not sure because I had suggestions already installed with the
pre-3.6-dev-builds.

To be honest, it's quite annoying, because the way I use it now is I
sometimes I open the suggestions view to fix a bunch of issues in the
recently edited classes (strictly avoiding recompilation of any
class). If once I have recompiled a class the I would have to restart
NetBeans to use suggestions again.
Comment 12 _ moser 2004-10-15 11:48:03 UTC
Created attachment 18315 [details]
Thread-dump for dead-locked IDE window
Comment 13 _ moser 2004-10-15 11:50:04 UTC
Sorry, I edited the wrong issue! Please ignore the thread-dump.
Comment 14 mslama 2004-10-20 12:42:12 UTC
I just tried on my fresh dev build and it looks fine. I have simple
project with 2 java sources. As I modify, save one java source and
build project using F11. Then I switch between 2 editor tabs and
suggestions view is updated as before. (Linux, JDK 1.5.0, hopefully it
is not Win specific) Pleas retest again and verify or reopen if you
are able to reproduce it. Thanks.
Comment 15 mslama 2004-10-20 12:42:50 UTC
My fresh NB dev build from 041020.
Comment 16 _ moser 2004-10-20 14:59:33 UTC
Sorry, but where can I get the Suggestions View module for the latest
dev builds of NB4? Is there any update-center or download page?
Comment 17 mslama 2004-10-20 15:05:05 UTC
I have CVS version on my machine. It is checked out as tasklist module
(with many submodules). When I then run ant from tasklist dir
(.../nbsrc/tasklist/ant it builds all its submodules to
nbbuild/netbeans. Then you can run IDE from there or copy it elsewhere
for testing. To checkout and build use:
cvs -q -z6 co standard
(then eventualy cvs -q -z6 up -d -P)
go to nbbuild ad run 'ant build-nozip' to get NB build at nbbuild/netbeans
build tasklist modules as given above
Comment 18 Marian Mirilovic 2005-07-12 10:16:51 UTC
closed
Comment 19 Quality Engineering 2008-12-23 14:32:32 UTC
This issue had *1 votes* before move to platform component


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo