Bug 41681 - [SDI] Editor loses top position on [Alt+G]
[SDI] Editor loses top position on [Alt+G]
Status: CLOSED FIXED
Product: platform
Classification: Unclassified
Component: Window System
3.x
PC Windows 95/98
: P2 (vote)
: 4.x
Assigned To: Milos Kleint
issues@platform
: FOCUS
: 41374 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-04 11:19 UTC by bht
Modified: 2008-12-23 14:29 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bht 2004-04-04 11:19:01 UTC
In some some simple cases, in SDI mode, the editor
loses top position
(disappears into the background) when [Alt+G] is
pressed.
In this testcase, the explorer window comes on top.

Product Version  = NetBeans IDE 3.6 RC2 (Build
200403312136)
Operating System = Windows 98 version 4.10 running
on x86
Java; VM; Vendor = 1.4.2_03; Java HotSpot(TM)
Client VM 1.4.2_03-b02; Sun Microsystems Inc.


How to reproduce:

- Create an empty userDir
- Start NetBeans
- Menu|Tools|Setup Wizard|Separate Windows Mode|Finish
- Maximise the NetBeans IDE Toolbar window
- Maximise the FileSystems Window
- Maximise the Editor Window
- Select File Systems window
- Navigate to node "examples/texteditor"
- Double-click on "class Ted"
- Click on the java source file tab.
- [Ctrl+F] "new Finder" [Enter] finds:
  "new Finder(this, textBox).show();"
- Position cursor on "Finder"
- Press [Alt+G]

Expected behavior:
- Finder.java should be opened in the editor and
should be on top

Actual behavior:
- The explorer window comes on top and obscures
the editor window
Comment 1 bht 2004-04-07 01:50:03 UTC
Other testcase:

- Create an empty userDir
- Start NetBeans
- Menu|Tools|Setup Wizard|Separate Windows Mode|Finish
- Maximise the NetBeans IDE Toolbar window
- Maximise the FileSystems Window
- Maximise the Editor Window
- Select File Systems window
- Navigate to node "examples/texteditor"
- Double-click on "class Ted"
- Click on the java source file tab.
- [Ctrl+O] "Open"
- Select a file from your local file system

Expected behavior:
- The selected file should be opened in the editor and should be on top

Actual behavior:
- The explorer window comes on top and obscures the editor window
- In some cases where the userdir is not empty, the output window is
on top

I think NetBeans has become annoying. It wasn't annoying before.
Comment 2 David Simonek 2004-06-18 14:22:19 UTC
*** Issue 41374 has been marked as a duplicate of this issue. ***
Comment 3 David Simonek 2004-06-18 14:26:08 UTC
I'm raising priority to P2, I understand this is annoying problem for
SDI users. (I'm not saying I know how to fix this :-)
Comment 4 Milos Kleint 2004-07-14 11:21:25 UTC
reassigning, will try to fix it.
Comment 5 Milos Kleint 2004-07-30 07:40:36 UTC
I've been debugging this yesterday and it seems like it's another
invokation of the focus problems, like #44278, #46188.
Comment 6 Milos Kleint 2004-08-03 13:00:55 UTC
fixed in trunk.
Comment 7 Zdenek Konecny 2005-07-08 14:03:31 UTC
I've marked it closed. It's too old and in current version isn't any text editor
in examples. 
Comment 8 Quality Engineering 2008-12-23 14:29:01 UTC
This issue had *1 votes* before move to platform component


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo