Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 41206 - J2EE debugging with Tomcat 5.0 starts too late, brakepoints are ignored at the begining
J2EE debugging with Tomcat 5.0 starts too late, brakepoints are ignored at th...
Status: RESOLVED WONTFIX
Product: javaee
Classification: Unclassified
Component: Debugger
3.x
PC Windows ME/2000
: P3 with 1 vote (vote)
: 6.x
Assigned To: Pavlo Tymoshenko
issues@javaee
:
: 70538 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-22 19:31 UTC by fassev
Modified: 2016-07-07 08:52 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fassev 2004-03-22 19:31:12 UTC
NetBeans 3.6 (Beta and RC 1): When debugging a 
J2EE application within a Tomcat, the debugging 
is enabled too late, so the start process of the 
Tomcat server, including the loading of server 
classes, predefined modules or extenssions etc. 
cannot be debugged. All breakpoints are ignored 
during the start process. Just after the 
deployment process is finished, the debugging is 
enabled and IDE steps into the break points as 
usually.

With NetBeans 3.5x it is possible to debug the 
start of Tomcat 4.x.
Comment 1 Martin Grebac 2004-03-23 08:13:42 UTC
 Well, in 3.5 it worked only with a luck - IDE was trying to attach to
the server in some increasing time intervals, so some code could have
been easily missed during the start, too. More, the approach lead to
connection errors if tomcat has been starting longer than we expected.
 So, in promoB (3.6) we are waiting for the server to start first as
we don't have an option of listening connectors yet. 
 Listening connectors support will be added in promoD, and we'll use
them to be able to fulfill your request and handle debugging of server
startup correctly.
Comment 2 fassev 2004-03-23 11:54:51 UTC
Please, could You tell, what is the target "promo-D" of NetBeans?
Comment 3 Marek Fukala 2004-03-23 12:50:14 UTC
The Promo-D is a code name for the next netbeans release. It is a
direct successor of netbeans 3.6 (Promo-B) and its version will be
very likely 4.0.
Comment 4 Martin Grebac 2004-04-21 09:30:47 UTC
this is not a defining feature
Comment 5 Libor Kotouc 2005-06-02 09:52:07 UTC
corner case, decreasing priority to P3 (approved by QE).
Comment 6 Sherold Dev 2006-01-06 09:45:41 UTC
*** Issue 70538 has been marked as a duplicate of this issue. ***
Comment 7 Martin Balin 2016-07-07 08:52:45 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo