Bug 40730 - Infinitive loop after install module and restart
Infinitive loop after install module and restart
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: -- Other --
3.x
PC Linux
: P2 (vote)
: 3.x
Assigned To: Jiri Rechtacek
issues@platform
: SPACE_IN_PATH
: 35356 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-03 15:09 UTC by Lukas Hasik
Modified: 2008-12-22 20:57 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
a proposed patch (605 bytes, patch)
2004-03-03 15:31 UTC, Jiri Rechtacek
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Hasik 2004-03-03 15:09:51 UTC
[nb200403021830] 

-run IDE with userdir with space in path
-try install module to IDE and let it restart

-module isnt restarted and message 
Exception in thread "main"
java.lang.NoClassDefFoundError:

-whenever you want to exit IDE it restarts again

happens only on unix. bug in runide.sh
Comment 1 Jiri Rechtacek 2004-03-03 15:28:23 UTC
*** Issue 35356 has been marked as a duplicate of this issue. ***
Comment 2 Jiri Rechtacek 2004-03-03 15:31:32 UTC
Created attachment 13794 [details]
a proposed patch
Comment 3 Jiri Rechtacek 2004-03-03 15:32:48 UTC
Attached patch was appiled.
Jardo, could you review this patch? Thanks
Comment 4 Jaroslav Tulach 2004-03-03 17:16:16 UTC
The problem was probably introduced by me, thanks for the fix. This
looks fine as it makes the "$userdir" behave the same as "$updatercp".
Comment 5 Marian Mirilovic 2004-03-05 12:11:42 UTC
verified in [nb_dev](200403041900)

Lukas, I tried only this scenario, I didn't check for regressions ......
Comment 6 Lukas Hasik 2004-03-05 13:52:59 UTC
i don't think that there could be any regressions. It only pass whole
userdir to quatation marks as args in class invocation so the only
case in which it could change something is the "space in userdir" -
thanks for verification. i'll mark as verified when it is commited to
release36 branch.
Comment 7 Jiri Rechtacek 2004-03-05 16:53:59 UTC
fix was intergrated in release36 branch.
Comment 8 Marian Mirilovic 2004-03-08 11:06:50 UTC
verified in [nb_release36](200403071830)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo