Bug 39489 - [SDI] focus problems after first compilation with hidden output
[SDI] focus problems after first compilation with hidden output
Status: VERIFIED DUPLICATE of bug 39751
Product: platform
Classification: Unclassified
Component: Window System
5.x
PC All
: P3 (vote)
: 5.x
Assigned To: Milos Kleint
issues@platform
SDI
: FOCUS, RANDOM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-02 15:02 UTC by David Simonek
Modified: 2008-12-22 20:42 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Simonek 2004-02-02 15:02:06 UTC
JDK 1.4.2, win XP, build from 2004/01/30, Separate
window mode.
Steps to reproduce:
1) Start IDE, clean userdir.
2) Tools/Setup wizard, switch to Separated win mode
3) Open some java source.
4) Make sure output window is closed.
5) Modify source (add space somewhere), then press
F9 to compile.
error: Focus is on output window, but should stay
in editor.
6) Close output window, bring focus back to editor.
7) Press F9 to compile (don't modify java source!)
error (sometimes): Focus switches to Filesystems,
should remain in editor. Unfortunately, this is
not happening all the time, it's probably focus
timing issue, I have reproduction rate only about
10% :-(
Comment 1 Lukas Hasik 2004-02-02 15:33:37 UTC
ok, I saw it too, but really don't know when happens or how to reproduce.
Comment 2 _ tboudreau 2004-02-10 14:57:34 UTC
Note also issue 39751 in which the bug is that the output window *doesn't* get focus after 
compiling (SDI).

Giving this issue to Jano - we need one answer as to what is the right thing before we 
change anything else.
Comment 3 jrojcek 2004-02-23 10:53:27 UTC
The focus should always stay in the editor.
Comment 4 Milos Kleint 2004-09-22 13:14:14 UTC
Dafe, I fixed the behaviour described in point 7 yesterday.

Now whenever the compilation window is opened, it's getting fronted.
if it already was opened, it doesn't get fronted anymore. But the
focus doesn't travel to other components anymore.
(at least on macos)
Comment 5 Milos Kleint 2004-09-22 14:04:04 UTC
reassigning
Comment 6 Milos Kleint 2004-09-22 15:06:32 UTC
should be fixed, now.
editor keeps focus even when a newly opened compiler output window
appears.
Comment 7 Zdenek Konecny 2005-07-12 12:42:57 UTC
This issue is old and I don't know what is the right behaviour in current
version (Build 200507110943), but now when the output is already opened the
editor is still focused after compilation. But when the output is closed before
compilation, after compilatiot the output is focused. Win 2000, JDK 1.6.0-ea 
Comment 8 Zdenek Konecny 2005-07-12 14:32:46 UTC

*** This issue has been marked as a duplicate of 39751 ***
Comment 9 Marian Mirilovic 2005-07-19 15:34:23 UTC
verified duplicate


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo