Bug 39450 - [WIN98] Focus problems after Alt-Tab [was:Can't open output window in SDI mode]
[WIN98] Focus problems after Alt-Tab [was:Can't open output window in SDI mode]
Status: VERIFIED DUPLICATE of bug 37554
Product: platform
Classification: Unclassified
Component: Window System
3.x
PC Windows 95/98
: P2 (vote)
: 3.x
Assigned To: mslama
issues@platform
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-31 19:41 UTC by bht
Modified: 2008-12-22 20:29 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bht 2004-01-31 19:41:07 UTC
Please refer to ussue 39204 on how to reproduce
this or for clues. It is the same thing except
there is no _permanent_ flicker.

I switch to SDI mode and try to run my project.
Some compiler error and the project does not run.
When I select Window|Output, then the output
window flickers up once but then again the main
window has the focus.
When I use [Alt+Tab] to select the output window
then the same thing happens.

Only if I minimise all windows except the output
window then I can see the the output window.

Why do ALL windows have the same icon in the task
bar? How can I switch windows in SDI mode with the
icons all the same?
Comment 1 bht 2004-02-01 01:44:15 UTC
The symptoms vary. Sometimes, when I see the editor, full screen, and
I locate on a word, when I type then the focus jumps to the main menu
bar and the typed characters cause menu selections.
Then again, I can work for a while without problems.
Other times, the output window is visible but it is empty although
there are compile errors. Clicking more than once on it then reveals
the output.
Other times, [Ctrl+K] does not work, presumably due to focus issues.
Comment 2 bht 2004-02-01 03:36:43 UTC
SDI doesn't work for me. I can see in the status bar that my project
compile has errors but the console is empty. There is no way to see
the errors, whatever I do. I give up and go back to an older version
Build 200310312030.
Comment 3 Marian Mirilovic 2004-02-02 07:48:29 UTC
Marek, please look at it.
Comment 4 mslama 2004-02-02 08:34:32 UTC
Please tell me what build shows this. I fixed issue #39204 on Friday
evening. So build 200401301900 or 200402011900 should work correctly.
Anyway I will try to reproduce on current dev build ie.200402011900.
Comment 5 bht 2004-02-02 08:51:13 UTC
I found the new issue in NetBeansIDE-dev-200401301900.zip
Indeed the issue #39204 appears to be fixed in this on my computer.
Comment 6 mslama 2004-02-02 09:11:48 UTC
I just tested on Win XP, JDK 1.4.2_03 200401301900, 200402011900 and
it seems ok. I can open Output window without any problem in SDI. When
I invoke Compile both from Editor and Explorer. When I use
Window->Output. The only problem is that whn Output window is opened
for the first time it is empty ie. no text. When I close and reopen it
it is ok. I tried to compile source without and with syntax error.
Both is ok. Is anyone else able to reproduce it?
Comment 7 mslama 2004-02-02 09:33:22 UTC
I filed separate issue for window icons in SDI #39460.
Comment 8 Lukas Hasik 2004-02-02 11:21:30 UTC
w2k, build 0201

- OW  is empty for first open with compilation error. I didn't see
this problem when I printed to console.
- focus behaves weird, I have class doing simple print. Just executing
it  for a few times and one time the focus finish in OW, one time in
Editor and sometimes even in Filesystems, dont know how I did it :(

- Marek, try fix the empty OW for start

-Bernard, I had no probles with opening of OW, are you sure that it
didn't open ? or it just didn't have focus so it 'hide' behind
maximized Editor?

-and I'm not sure about the P1, user can work, it's just annoying and
confusing that OW is empty after compilation error, when this will be
fixed I dont see any reason for P1.
Comment 9 mslama 2004-02-02 11:58:23 UTC
Problem with empty Output windows: Lukas please file separate issue
against core/output.
Comment 10 bht 2004-02-02 12:09:30 UTC
Lukas,

I don't have an opinion on the priority. It's just so bad and
confusing for me that I stop using this version entirely. I can't work
with it.

Please consider that the other issue #39204 that was fixed before this
was only reproducable in Win NT and Win98. I use Win98.

I would suggest that someone with Win98 or Win NT plays with it for
some time after the most obvious issue is fixed.

Comment 11 mslama 2004-02-02 12:17:46 UTC
> Please consider that the other issue #39204 that was fixed before this
> was only reproducable in Win NT and Win98. I use Win98.
It is NOT true. I was able to reproduce #39204 without any problem on
Win XP.

Bernard what JDK do you use?
Comment 12 Lukas Hasik 2004-02-02 12:31:28 UTC
Bernard, 
-I was able to reproduce 39204 without any problems on win XP. I don't
see any reason why I'd not be able reproduce this one ;) (but it can
be only w98 problem, of course)

-I dont have w98, I'll try to find some, but I still confused about
what exactly happens. So I sumarize this growing issues one more:
 1, OW opens empty first time after compilation - I filed new issue 39468
 2, the icons - Jano closed it as WONTFIX, it follows the ui spec
 3, focus ... that's what I'm confused about. 
    - Just typing  in maximized window gives focus to the main window?
    - you _really_ cannot open OW sometimes ? I'm not talking about
empty OW now, I mean NO output window.

anyway, thanks for report
and answer, please, we'd like to fix it till 3.6 RC but we need more
info how to reproduce or what exactly happend - try be strict, it's
sometime hard to understand what others mean when you don't see it on
monitor ;)

decreasing priority to P2
Comment 13 Jan Chalupa 2004-02-02 14:16:25 UTC
I've just tried to reproduce it with Win NT 4.0 SP6 + build
#200402011900 in SDI mode. I did see the OW empty on first use, but I
didn't run into any focusing issues. Bernard, I'd appreciate if you
could provide a step-by-step scenario (starting with empty userdir) to
reproduce the behavior. Thank you in advance.
Comment 14 David Simonek 2004-02-02 15:02:47 UTC
I was succesfull in reproducing some minor focus-related annoyances, I
reported them in separate issue , however output window was always
opened as it should (except for focus issues).
Comment 15 David Simonek 2004-02-02 15:04:20 UTC
Number of separate issue is 39489.
Comment 16 mslama 2004-02-02 16:55:24 UTC
I just tested on Win 98 SE:
  Product Version       = NetBeans IDE Dev (Build 200402011900)
  Operating System      = Windows 98 version 4.10 running on x86
  Java; VM; Vendor      = 1.4.2_03; Java HotSpot(TM) Client VM
1.4.2_03-b02; Sun Microsystems Inc.

and I saw no major issues like cannot open Output window in SDI. If we
will not be able to reproduce => investigate we cannot do anything =>
we will close this issue as unreproducible. Sorry.
Comment 17 bht 2004-02-02 19:39:25 UTC
JDK = 1.4.1; Java HotSpot(TM) Client VM 1.4.1-b21

This is a testcase that took me 1 minute to find. It reproduces always.

- Start up BetBeans with empty userDir
- close the Welcome file
- Menu|Tools|Setup Wizard|Separate Windows Mode, Finish
- Maximise main window
- [Alt+Tab]
- In the graphical window list, select the other NetBeans icon
   by holding down the {Alt] kyey and pressing [Tab] repeatedly.
   - Why has the explorer the same icon as the main window ???
     - It there an issue number for this?


Pause here.

The Explorer window briefly opens, then loses the focus.
When I repeat [Alt+Tab], then it works.
This can be reproduced indefinitely. The explorer window gains focus
only every second cycle.

This case seems to be in line with my other observations that the main
window
can get the focus when it should not while simply typing in the editor.

I don't know whether this is the only issue, probably not.
I don't think that this is a minor focus issue, because it depends on
the context in which this happens. Obviously, the context of this
testcase is trivial, but the fact that my attempt is trivial is no
proof that other contexts must also be trivial. E.g. when you are
typing in the editor and your key strokes end up in the menu bar that
is not trivial.
Comment 18 mslama 2004-02-03 09:07:32 UTC
Please upgrade JDK to 1.4.2_03. There was some focus bugs fixed in AWT
between 1.4.1 and 1.4.2.
Comment 19 Lukas Hasik 2004-02-03 09:08:49 UTC
thanks for really nice test case.
I've tryed it on my XP and it work as expected - maybe it's really w98
problem when you say it happens everytime. I have to try on w98 later.

About the same icons in SDI - issue #39460 

You can try "Compact Window Mode" aka "MDI" for now. It's possible to
maximize Editor in it too. 
Comment 20 mslama 2004-02-03 09:14:40 UTC
Problem with pressing Alt-TAB moving focus to main menu is known and
fixed already in JDK 1.5 ie. it is JDK/Swing bug. Please check issue
#37554. It looks like duplicate of #37554 now.
Comment 21 Lukas Hasik 2004-02-03 09:38:28 UTC
I've tryed with jdk1.4.1 and I'm able to reproduce your test case.
Definitelly duplicate of issue 37554. 

I'm closing this issue as duplicate. Feel free to reopen if you don't
agree.

Other issues are filed separately :
issue #39489 - focus problem after compilation
issue #39460 - Icons of all windows are the same 
issue #39468 - OW is empty when opened  first time with compilation errors




*** This issue has been marked as a duplicate of 37554 ***
Comment 22 bht 2004-02-03 10:25:23 UTC
Thanks for looking at this.

Your logic seems plausible but for me, it doesn't provide a solution
for SDI with JDK 1.4.1.

The focus issue with SDI with JDK 1.4.1 is not exactly a duplicate of
issue 37554 as described.

Otherwise I would have the same problems with the older Build
200310312030.

With the older build, the focus problem is also visible and sometimes
annoying, but that has not yet prompted me to file a bug.

This time, I had to give up working with the IDE because of severe
problems, so there must be additional combinations or separate issues.
I will see what I can do to find out more.
Comment 23 Marian Mirilovic 2004-02-27 13:46:05 UTC
verified duplicate


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo