Bug 39171 - Can not execute JSP
Can not execute JSP
Status: VERIFIED FIXED
Product: serverplugins
Classification: Unclassified
Component: Infrastructure
3.x
PC Windows XP
: P1 (vote)
: 4.x
Assigned To: Nam Nguyen
issues@serverplugins
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-23 12:20 UTC by capSS
Modified: 2006-06-05 00:39 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description capSS 2004-01-23 12:20:28 UTC
I can not execute any JSP on NB builded from 
current sources.

Steps to reproduce:
1. Get and build latest sources from cvs
2. Create webmodule
3. Create JSP
4. Execute it

You will got NPE:
Internal HTTP server running on port 8082
INFORMATIONAL *********** Exception occurred 
************ at Fri Jan 23 15:15:24
 MSK 2004
java.lang.NullPointerException
        at org.netbeans.modules.j2ee.deployment.
impl.TargetServer.deploy(TargetS
erver.java:363)
[catch] at org.netbeans.modules.j2ee.deployment.
execution.ServerExecutor.doDeplo
y(ServerExecutor.java:127)
        at org.netbeans.modules.j2ee.deployment.
execution.ServerExecutor.access$
000(ServerExecutor.java:43)
        at org.netbeans.modules.j2ee.deployment.
execution.ServerExecutor$2.run(S
erverExecutor.java:83)
        at org.openide.util.Task.run(Task.java:
136)
        at org.openide.util.RequestProcessor$Task.
run(RequestProcessor.java:330)

        at org.openide.util.
RequestProcessor$Processor.run(RequestProcessor.
java
:680)
Comment 1 capSS 2004-01-23 12:21:06 UTC
I think this should be P1 bug!
Comment 2 Petr Jiricka 2004-01-23 16:45:18 UTC
Well, this works for me. Nam, can you reproduce this?

capSS, did you start with a clean user directory, or did you have an
old one? Thanks.
Comment 3 Nam Nguyen 2004-01-23 17:42:35 UTC
The test case work fine for me too, with either clean userdir or
existing webapps.  I notice hte NPE stack line number seems to be odd.
 It cannot be dtarget that is null.  Is there any chance that the NPE
is further down in the code of dtarget.getConfigurationFile ?
Comment 4 capSS 2004-01-23 20:34:37 UTC
I've used my work directory from NevadaFixes

But I've created new web-module in it. And try to start this 
web-module.
I'll try to use clear userdir tomorrow.

We can reproduce this bug on the second machine. With almost the smae 
configuration and userdir from NevadaFixes.

BTW the correct line number wich rises NPE is 361 not 363. I've tried 
to make fix myself and linenumber changed.

BTW 2. The version of TargetServer.java is 1.18
Comment 5 Nam Nguyen 2004-01-24 06:55:16 UTC
The problem I believe is in J2eeDeployementLookup.getStorage using
FileUtil.fromFile to get primary config FO.  I fixed this earlier this
week, but not I see that it was partial only in one logic branch.  I
think I cover all logic branches in this fix and make sure a non-null
configuration storage is returned or an exception will be thrown to
help debugging and avoid failure deeper down in the
deployment/configuration code.
If this does not fix the problem, please reopen the bug.  If so this
time hopefully we would have more information to fix.
Comment 6 capSS 2004-01-28 10:23:17 UTC
Yes, seems working now
Thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo