Bug 39170 - IllegalStateException clicking on values in the properties editor
IllegalStateException clicking on values in the properties editor
Status: RESOLVED DUPLICATE of bug 36400
Product: utilities
Classification: Unclassified
Component: Properties
3.x
All All
: P3 (vote)
: TBD
Assigned To: issues@utilities
issues@utilities
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-23 11:47 UTC by aldobrucale
Modified: 2004-01-23 12:54 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description aldobrucale 2004-01-23 11:47:23 UTC
When clicking the table rows in the property 
editor I get the following stack trace printed on 
the output window:

java.lang.IllegalStateException: This must happen 
in the event thread!
        at 
org.openide.awt.Actions$Bridge.propertyChange
(Actions.java:281)
        at 
java.beans.PropertyChangeSupport.firePropertyChang
e(PropertyChangeSupport.java:252)
        at 
org.openide.util.SharedClassObject.firePropertyCha
nge(SharedClassObject.java:386)
        at 
org.openide.util.SharedClassObject.putProperty
(SharedClassObject.java:276)
        at 
org.openide.util.actions.SystemAction.setEnabled
(SystemAction.java:108)
        at 
org.openide.util.actions.CallbackSystemAction.upda
teEnabled(CallbackSystemAction.java:140)
        at 
org.openide.util.actions.CallbackSystemAction.setA
ctionPerformer(CallbackSystemAction.java:118)
        at 
org.netbeans.modules.properties.PropertiesOpen$3.r
un(PropertiesOpen.java:845)
        at org.openide.util.Task.run
(Task.java:136)
        at 
org.openide.util.RequestProcessor$Task.run
(RequestProcessor.java:330)
        at 
org.openide.util.RequestProcessor$Processor.run
(RequestProcessor.java:680)
java.lang.IllegalStateException: This must happen 
in the event thread!
        at 
org.openide.awt.Actions$Bridge.propertyChange
(Actions.java:281)
        at 
java.beans.PropertyChangeSupport.firePropertyChang
e(PropertyChangeSupport.java:252)
        at 
org.openide.util.SharedClassObject.firePropertyCha
nge(SharedClassObject.java:386)
        at 
org.openide.util.SharedClassObject.putProperty
(SharedClassObject.java:276)
        at 
org.openide.util.actions.SystemAction.setEnabled
(SystemAction.java:108)
        at 
org.openide.util.actions.CallbackSystemAction.upda
teEnabled(CallbackSystemAction.java:140)
        at 
org.openide.util.actions.CallbackSystemAction.setA
ctionPerformer(CallbackSystemAction.java:118)
        at 
org.netbeans.modules.properties.PropertiesOpen$3.r
un(PropertiesOpen.java:845)
        at org.openide.util.Task.run
(Task.java:136)
        at 
org.openide.util.RequestProcessor$Task.run
(RequestProcessor.java:330)
        at 
org.openide.util.RequestProcessor$Processor.run
(RequestProcessor.java:680)
Comment 1 Marian Petras 2004-01-23 12:54:58 UTC
The exception and its stack trace is exactly the same as for bug
#36400 ("IllegalStateException when opening properties file"). I am
marking it as a duplicate of the bug.

*** This issue has been marked as a duplicate of 36400 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo