Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 38810 - [SDI] It's impossible invoke actions from main menu by keyborad
[SDI] It's impossible invoke actions from main menu by keyborad
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Window System
3.x
All All
: P2 (vote)
: 3.x
Assigned To: Milos Kleint
issues@platform
SDI
: A11Y
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-15 11:42 UTC by Marian Mirilovic
Modified: 2008-12-22 16:49 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Mirilovic 2004-01-15 11:42:21 UTC
[nb_dev](200401141900), [jdk1.4.2_03]
reproducible on Linux RH9/Gnome and Sol8/CDE

Steps to reproduce:
- run IDE
- switch to SDI
- open some file - cursor is in edited document
- push Alt-F
-> File main menu is rolled-down
- try select "New..." menu item and press Enter
-> nothing happend !

It's high priority A11Y issue.
Comment 1 Marian Mirilovic 2004-01-15 11:43:13 UTC
By the way it seems like invoking main menu doesn't change focus to
main window - this is the reason - I think.
Comment 2 Peter Zavadsky 2004-01-16 13:03:07 UTC
First I thought it is because I removed some code from
ShortcutAndKeyEventProcessor which was dealing with this in older SDI.

But as I tested, this issue, is also in 3.4 also 3.5.1.
Comment 3 David Simonek 2004-02-09 15:35:58 UTC
Passing to Milos.
Comment 4 Milos Kleint 2004-02-10 12:39:59 UTC
fiuxed in trunk by putting main window to front when processing shortcuts.
Comment 5 Milos Kleint 2004-02-10 13:18:35 UTC
reopening..
Comment 6 Milos Kleint 2004-02-10 16:06:20 UTC
this time I think it's fixed correctly.
Comment 7 Marian Mirilovic 2004-02-16 16:13:12 UTC
verified in [nb_dev](200402151900)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo