Bug 38599 - Deadlock on instantiating a template with overlapping bundles
Deadlock on instantiating a template with overlapping bundles
Status: RESOLVED FIXED
Product: utilities
Classification: Unclassified
Component: Properties
3.x
All All
: P3 (vote)
: 3.x
Assigned To: Jesse Glick
issues@utilities
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-10 18:43 UTC by _ tboudreau
Modified: 2004-01-28 18:34 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Partial thread dump - will try to reproduce w/ bigger scrollback buffer (14.59 KB, text/plain)
2004-01-10 18:44 UTC, _ tboudreau
Details
Complete thread dump - it's totally reproducable (19.00 KB, text/plain)
2004-01-10 18:47 UTC, _ tboudreau
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ tboudreau 2004-01-10 18:43:07 UTC
Tried using the Callable Action template when I
already had a Bundle.Properties in the directory.  

A dialog titled "Overlapping Bundles" pops up but
never paints itself - NetBeans hangs at this point.

Not sure if it's an Apisupport thing or a general
thing, so filing it here first.  Will try to
reproduce.
Comment 1 _ tboudreau 2004-01-10 18:44:04 UTC
Created attachment 12818 [details]
Partial thread dump - will try to reproduce w/ bigger scrollback buffer
Comment 2 _ tboudreau 2004-01-10 18:47:29 UTC
Created attachment 12819 [details]
Complete thread dump - it's totally reproducable
Comment 3 _ tboudreau 2004-01-10 18:48:07 UTC
Seems to be easy to reproduce.

FWIW, dual processor machine, running NetBeans w/ -server...
Comment 4 Jesse Glick 2004-01-28 01:40:24 UTC
Actually a bug in properties module, but the code in question was
added by me long ago and of interest mainly to apisupport module.
Trying to show a dialog from a Datasystems callback method, which is
not good; will just pick "Append" for you instead.
Comment 5 _ tboudreau 2004-01-28 08:07:14 UTC
Seems like a good idea not to bother the user with the overlapping bundles thing - I 
can't imagine any case where the answer would be "yes, please delete everything so all 
my existing classes break" :-)  
Comment 6 Jesse Glick 2004-01-28 18:34:13 UTC
committed   * Up-To-Date  1.64       
properties/src/org/netbeans/modules/properties/Bundle.properties
committed   * Up-To-Date  1.48       
properties/src/org/netbeans/modules/properties/PropertiesFileEntry.java


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo