Bug 38385 - Driver list refresh problem
Driver list refresh problem
Status: VERIFIED FIXED
Product: db
Classification: Unclassified
Component: Code
3.x
PC All
: P2 (vote)
: 4.x
Assigned To: Radko Najman
issues@db
: REGRESSION
: 39987 41674 44377 45689 (view as bug list)
Depends on: 40290
Blocks: 38384
  Show dependency treegraph
 
Reported: 2004-01-05 13:14 UTC by Radko Najman
Modified: 2004-08-13 12:10 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Radko Najman 2004-01-05 13:14:21 UTC
When the driver is removed, the list is not refreshed.

Workaround:
Call Refresh action from Drivers popup menu.
Comment 1 Radko Najman 2004-02-06 16:56:23 UTC
Fixed.
Comment 2 Jiri Skrivanek 2004-02-09 12:57:42 UTC
Verified in build 20040209-0907.
Comment 3 Jiri Skrivanek 2004-02-09 13:16:53 UTC
Unfortunately, I found a case which produces this bug again. Do the
following:

1) run IDE with clean userdir
2) add a driver under Databases -> Drivers node (e.g. Oracle)
3) remove that driver => it is OK
4) add a driver (e.g. the same as before)
5) restart IDE with the same userdir
6) repeat steps 2-5
7) remove driver => driver list is NOT refreshed

Tested in build 20040209-0907, JDK1.4.2_03, WindowsXP.
Comment 4 Radko Najman 2004-02-19 17:47:56 UTC
It seems the issue is caused by a problem with Lookup cache. Sometimes
the requested driver objects are not correctly constructed by Lookup
but they are returned from the Lookup cache.

For more info see:
http://db.netbeans.org/issues/show_bug.cgi?id=40290
Comment 5 Radko Najman 2004-02-19 17:50:03 UTC
*** Issue 39987 has been marked as a duplicate of this issue. ***
Comment 6 Jiri Skrivanek 2004-02-19 19:05:24 UTC
So, until it is fixed we need again Refresh action on drivers node.
What do you think?
Comment 7 Radko Najman 2004-02-20 08:58:13 UTC
No, Refresh action uses Lookup as weel. It doesn't help in this case.
Comment 8 Radko Najman 2004-04-06 17:09:35 UTC
*** Issue 41674 has been marked as a duplicate of this issue. ***
Comment 9 Radko Najman 2004-04-07 19:28:38 UTC
*** Issue 41674 has been marked as a duplicate of this issue. ***
Comment 10 Jiri Skrivanek 2004-04-08 07:47:10 UTC
Issue 40290 was marked as fixed but it didn't have any influence on
this issue. I tested it in build 200404051800 and added driver didn't
appear in the list.
Comment 11 Radko Najman 2004-06-08 16:51:14 UTC
*** Issue 44377 has been marked as a duplicate of this issue. ***
Comment 12 Radko Najman 2004-07-14 17:03:56 UTC
Private driver cache implemented in JDBCDriverManager. Drivers stored
in this cache are used instead of the drivers taken from Lookup. This
should hopefully help to solve this issue.
Comment 13 Radko Najman 2004-07-14 17:07:42 UTC
*** Issue 45689 has been marked as a duplicate of this issue. ***
Comment 14 dmladek 2004-07-16 13:31:12 UTC
I'm testing it and for last 2 days has'n been able to reproduce the bug.
It's a good sign, but I'm not gonna very it yet.
Comment 15 dmladek 2004-07-27 15:22:23 UTC
Seems that it is really fixed. It hasn't happened me since Radko fixed.
Marking it as fixed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo