Bug 38211 - A problem with using IE external browser in the IDE.
A problem with using IE external browser in the IDE.
Status: VERIFIED FIXED
Product: ide
Classification: Unclassified
Component: Extbrowser
3.x
PC Windows XP
: P3 (vote)
: 3.x
Assigned To: Martin Grebac
issues@ide
: RANDOM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-18 15:52 UTC by Marek Fukala
Modified: 2004-03-15 14:36 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marek Fukala 2003-12-18 15:52:21 UTC
[20031217]
There is a problem with opening MS Internet
Explorer browser from the IDE. The problem is not
exactly reproducible and it happens quite seldom.
You can try to reproduce it by setting IDE default
browser to IE and force it to open by executing a
JSP or viewing a HTML page. If you are the lucky
one you will got the following annotation exception:

Annotation: Could not access the URL through the
external browser. Check the browser configuration.
 From the Tools menu, choose Options.  In the
Options window, expand the IDE Configuration node.
 Then expand the Server and External Tool Settings
node followed by the Web Browsers node. Select the
external browser type and modify the Browser
Executable property if necessary.
org.netbeans.modules.extbrowser.NbBrowserException:
org.netbeans.modules.extbrowser.NbBrowserException:
DdeConnect errno >400A< when connecting to server
IEXPLORE, topic WWW_OpenURL.
	at
org.netbeans.modules.extbrowser.NbDdeBrowserImpl$URLDisplayer.dispatchURL(NbDdeBrowserImpl.java:290)
	at
org.netbeans.modules.extbrowser.NbDdeBrowserImpl$URLDisplayer.run(NbDdeBrowserImpl.java:229)
[catch] at java.lang.Thread.run(Thread.java:534)


... and the browser doesn't open the specified
page. The browser is started but the needed URL is
not displayed.
Comment 1 Martin Grebac 2004-01-28 12:51:24 UTC
Are you still encoutering the problem with the latest build? It should
have been at least improved with the latest fixes. If you're still
getting this - how often does it happen?
Comment 2 Marek Fukala 2004-01-28 17:30:24 UTC
I haven't seen this for quite a long time. Currently I am using
Mozilla so I'll try to switch to the IE for a few days to make certain
the problem is gone.
Comment 3 Martin Grebac 2004-02-03 10:45:40 UTC
Any news?
Comment 4 Marek Fukala 2004-02-03 11:38:14 UTC
nope
Comment 5 Martin Grebac 2004-02-03 11:41:17 UTC
Ok then, marking as fixed.
Comment 6 Marek Fukala 2004-03-15 14:36:44 UTC
seems to be fixed - I'll reopen this if encounter the problem again


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo