Bug 38149 - [JDK1.5.0] Lost focus indication after escaping inline property editor
[JDK1.5.0] Lost focus indication after escaping inline property editor
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Explorer
3.x
PC Windows XP
: P4 (vote)
: 4.x
Assigned To: Martin Krauskopf
issues@platform
: FOCUS, JDK_SPECIFIC
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-16 13:20 UTC by Milan Kubec
Modified: 2008-12-22 20:42 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Milan Kubec 2003-12-16 13:20:04 UTC
Steps to reproduce:

1) Click some property with inline property editor
2) Press Space to enter edit mode
3) Press Escape to cancel changes

Blue background indicating selected line in
property sheet disapears. But the component still
has focus and blue background is drawn when moving
up or down.
Comment 1 _ tboudreau 2003-12-16 17:02:22 UTC
Hmm.  There were some painting hacks put in specifically for the radio
button boolean editor that I can probably take out now...
Comment 2 _ tboudreau 2004-01-10 12:43:04 UTC
The painting hacks are gone - is this still a problem?
Comment 3 _ tboudreau 2004-01-29 16:40:03 UTC
Fixed in trunk, BaseTable v. 1.10
Comment 4 Milan Kubec 2004-01-30 09:19:22 UTC
The behavior is still the same in dev-200401291900. Is it supposed to
be in this build?
Comment 5 _ tboudreau 2004-01-30 12:59:04 UTC
Depends when the build was built - I integrated the fix around 6:30 in the evening 
yesterday, Prague time.  Tested it on a private 1.5 build that I got from the JDK team 
to test the window modality fix, so I'm not sure how it matches the current 1.5 builds.
Comment 6 Milan Kubec 2004-02-04 14:33:23 UTC
Seems to be still there, but it only shows this behavior on comboboxes
now. 

The behavior is different even on JDK 1.4.2. The focus is still on the
correct line after escaping but on comboboxes the highlight blinks.
Comment 7 _ tboudreau 2004-02-04 17:27:00 UTC
Ugh.  I spent two weeks of my life in the last year just making combo boxes work at all 
normally on a single click in the property sheet.  I'll see what I can do, but if it flashes, it 
flashes.
Comment 8 Milan Kubec 2004-02-05 08:19:09 UTC
Flashing is not the problem of this issue, it is the lost focus on JDK
1.5.0 on comboboxes. 

It would be nicer without flashing though :-).
Comment 9 _ tboudreau 2004-02-09 10:52:20 UTC
Moving to Promotion D, but will look at it if there's time.  The issue is fixed for everything 
except combo boxes.  These are particularly difficult, and I don't want to fix it on 1.5.0 by 
breaking it on 1.4.2, which would be pretty easy to do.
Comment 10 Marian Mirilovic 2004-12-23 10:42:22 UTC
I think now we can fix it for JDK1.5.0
Comment 11 Martin Krauskopf 2005-02-08 16:23:06 UTC
I'm not able to reproduce the problem with the lost focus in the
current build. Tried with WinXP/Linux/1.4.2/1.5.0. Please reopen if it
is still happening.
Comment 12 Milan Kubec 2005-02-14 10:15:06 UTC
Yes, problem disapeared, verified in dev-200502131900.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo