Bug 37736 - CVS trunk broken
CVS trunk broken
Status: RESOLVED FIXED
Product: serverplugins
Classification: Unclassified
Component: Infrastructure
3.x
All All
: P1 (vote)
: 4.x
Assigned To: Nam Nguyen
issues@serverplugins
http://j2eeserver.netbeans.org/source...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-04 10:32 UTC by _ tboudreau
Modified: 2006-06-05 00:38 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
hotfix patch file to make the cvs trunk buildable again (378 bytes, patch)
2003-12-04 11:09 UTC, _ tboudreau
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description _ tboudreau 2003-12-04 10:32:09 UTC
compile:
    [javac] Compiling 95 source files to 
C:\space\nb_all\j2eeserver\src
    [javac] 
C:\space\nb_all\j2eeserver\src\org\netbeans\modul
es\j2ee\deployment\
impl\ServerString.java:49: variable targets 
might not have been initialized
    [javac]             return;
    [javac]             ^
    [javac] Note: Some input files use or 
override a deprecated API.
    [javac] Note: Recompile with -deprecation 
for details.
    [javac] 1 error
Comment 1 _ rkubacki 2003-12-04 10:59:52 UTC
Compiles with JDK1.4.0 but doesn't work with JDK1.4.2 (+Ant 1.5.3)

The reason should be:
j2eeserver/src/org/netbeans/modules/j2ee/deployment/impl/ServerString.java
revision 1.6
date: 2003/12/03 20:59:45;  author: nnguyen;  state: Exp;  lines: +26 -5
IN=18221 Make sure there is alway a default server
----------------------------
Comment 2 _ tboudreau 2003-12-04 11:09:23 UTC
I've put in a hotfix so the trunk is buildable again, but you need 
to review it - I have no idea if the targets variable should be 
null, or what it does - it just compiles now.
Comment 3 _ tboudreau 2003-12-04 11:09:55 UTC
Created attachment 12412 [details]
hotfix patch file to make the cvs trunk buildable again
Comment 4 Nam Nguyen 2003-12-04 16:18:35 UTC
I put in the actual fix.  The final variable targets should be not null.
Thanks Tim for taking care of this.
I wonder if I shoudl use 1.4.2 too.  Why continuous build does not use
1.4.2?
Comment 5 _ tboudreau 2003-12-04 20:54:29 UTC
No idea.  I filed issue 37761 against nbbuild for them to upgrade the
compiler.

Now the question is, how do we mail the golem to California?
Comment 6 Petr Jiricka 2003-12-05 12:52:12 UTC
Nam, so can this be marked as FIXED?
Comment 7 Nam Nguyen 2003-12-05 16:13:44 UTC
Fix the status :-).  I need this habit now.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo