Bug 37632 - Wrong focus indication
Wrong focus indication
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Terminalemulator
3.x
PC Linux
: P3 (vote)
: 6.x
Assigned To: Peter Zavadsky
ivan
: FOCUS
: 37630 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-01 14:18 UTC by Jiri Rechtacek
Modified: 2008-12-23 08:10 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Rechtacek 2003-12-01 14:18:44 UTC
[dev build 031201] After external execution
ColorPicker (for example) the focus holds Output
window but winsys indicates focus of Filesystems
tab (where was before execution).
(Note: other issue about the focus s by terminal
window is issue 37630)
Comment 1 Peter Zavadsky 2003-12-02 13:54:37 UTC
*** Issue 37630 has been marked as a duplicate of this issue. ***
Comment 2 Peter Zavadsky 2003-12-02 14:16:04 UTC
It is a problem in output.. OutputTabInner (which is now the inner
tab) requests focus, but doesn't activate the output window before.
Comment 3 Peter Zavadsky 2003-12-02 15:40:47 UTC
Fixed in [trunk]

core/ouput/../OutputView.java 1.7

core/windows/../view/DefaultView.java 1.11
                    /ViewHierarchy.java 1.6

Note: core/output - it was not activated output window while its tab
requested focus,

core/windows - there was not preserved focus while updating GUI. It
coudl happen that focus owner could be temporary removed from
hierarchy (because part of removing split pane), then added, but it
lost focus. Now it is preserved.
Comment 4 Peter Zavadsky 2004-01-08 14:19:53 UTC
It was forgotten to mark as fixed.
Comment 5 Marian Mirilovic 2004-02-24 17:14:17 UTC
verified in [nb_dev](200402221900)
Comment 6 Quality Engineering 2008-12-23 08:10:41 UTC
moving terminal emulator issues to terminalemulator component.
To see the correct version and target milestone of this issue look at Issue
Activity table.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo