Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 37186 - Very large properties window.
Very large properties window.
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Explorer
3.x
PC Linux
: P3 (vote)
: 3.x
Assigned To: _ tboudreau
issues@platform
:
Depends on: 31896
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-13 09:15 UTC by ehucka
Modified: 2008-12-22 19:29 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ehucka 2003-11-13 09:15:56 UTC
NB build 200311130740

Select for example 20 java classes and invoke
Properties action on them.

Very large properties window will be opened.
Comment 1 Marian Mirilovic 2003-11-13 09:23:39 UTC
Sorry Eman, what does it mean "Very large properties window", coul you
 be more specific? :)
Comment 2 ehucka 2003-11-13 09:43:32 UTC
Steps to reproduce:

1. run IDE
2. after startup select e.g. 30 classes (dont't make any other actions
befor it)
3. invoke properties action 

Properties dialog has in its footer a list of selected files - this
list is not collapsed after startup and it is displayed whole.

I've seen a window with size [9000,300], it can be called LARGE. :) 
Comment 3 Marian Mirilovic 2003-11-13 10:05:48 UTC
Ok, I cannot reproduce it, but Eman can.
Comment 4 _ tboudreau 2003-11-13 12:25:41 UTC
Okay, probably I just need to set a maximum size on the description 
component - the layout manager is just asking the label for its preferred 
size, and it's answering something very very big. 
Comment 5 _ tboudreau 2003-11-15 16:59:16 UTC
Fixed on the property panel rewrite branch
Comment 6 _ tboudreau 2003-12-09 09:37:01 UTC
Property panel rewrite branch merged.
Comment 7 ehucka 2004-02-24 16:37:21 UTC
verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo