Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 36800 - Trying to reorder columns throws Exception
Trying to reorder columns throws Exception
Status: VERIFIED DUPLICATE of bug 36708
Product: platform
Classification: Unclassified
Component: Explorer
3.x
PC Windows ME/2000
: P3 (vote)
: 3.x
Assigned To: _ tboudreau
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-23 16:10 UTC by santhosh
Modified: 2008-12-22 23:42 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
ScreenShot (4.60 KB, image/gif)
2003-10-23 16:12 UTC, santhosh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description santhosh 2003-10-23 16:10:44 UTC
when netbeans is launched in windows look and 
feel, the table headers of property sheet are 
shown(in metal they are not visible). try to drag 
them. following exception is thrown:

java.lang.IllegalArgumentException: Reordering 
not supported
	at 
org.openide.explorer.propertysheet.SheetColumnMode
l.moveColumn(SheetColumnModel.java:135)
	at 
javax.swing.plaf.basic.BasicTableHeaderUI$MouseInp
utHandler.setDraggedDistance
(BasicTableHeaderUI.java:216)
	at 
javax.swing.plaf.basic.BasicTableHeaderUI$MouseInp
utHandler.mouseDragged
(BasicTableHeaderUI.java:195)
	at 
java.awt.AWTEventMulticaster.mouseDragged
(AWTEventMulticaster.java:257)
	at 
java.awt.AWTEventMulticaster.mouseDragged
(AWTEventMulticaster.java:257)
	at 
java.awt.Component.processMouseMotionEvent
(Component.java:5182)
	at 
javax.swing.JComponent.processMouseMotionEvent
(JComponent.java:2776)
	at java.awt.Component.processEvent
(Component.java:4935)
	at java.awt.Container.processEvent
(Container.java:1566)
	at java.awt.Component.dispatchEventImpl
(Component.java:3639)
	at java.awt.Container.dispatchEventImpl
(Container.java:1623)
	at java.awt.Component.dispatchEvent
(Component.java:3480)
	at 
java.awt.LightweightDispatcher.retargetMouseEvent
(Container.java:3450)
	at 
java.awt.LightweightDispatcher.processMouseEvent
(Container.java:3182)
	at 
java.awt.LightweightDispatcher.dispatchEvent
(Container.java:3095)
	at java.awt.Container.dispatchEventImpl
(Container.java:1609)
	at java.awt.Window.dispatchEventImpl
(Window.java:1590)
	at java.awt.Component.dispatchEvent
(Component.java:3480)
[catch] at java.awt.EventQueue.dispatchEvent
(EventQueue.java:450)
	at 
java.awt.EventDispatchThread.pumpOneEventForHierar
chy(EventDispatchThread.java:197)
	at 
java.awt.EventDispatchThread.pumpEventsForHierarch
y(EventDispatchThread.java:150)
	at java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:144)
	at java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:136)
	at java.awt.EventDispatchThread.run
(EventDispatchThread.java:99)
Comment 1 santhosh 2003-10-23 16:12:42 UTC
Created attachment 11949 [details]
ScreenShot
Comment 2 _ tboudreau 2003-11-15 19:43:01 UTC

*** This issue has been marked as a duplicate of 36708 ***
Comment 3 Marian Mirilovic 2004-03-16 09:05:09 UTC
verified duplicate,
by the way it's already fixed in incoming NB3.6


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo