Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 36584 - Request for new Wizard API review
Request for new Wizard API review
Status: VERIFIED WONTFIX
Product: platform
Classification: Unclassified
Component: Dialogs&Wizards
3.x
All All
: P3 (vote)
: 4.x
Assigned To: Jiri Rechtacek
issues@platform
http://openide.netbeans.org/proposals...
2003-11-7
: API_REVIEW
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-14 16:33 UTC by Jiri Rechtacek
Modified: 2008-12-22 20:54 UTC (History)
4 users (show)

See Also:
Issue Type: TASK
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Rechtacek 2003-10-14 16:33:43 UTC
I post the intention to make new Wizard API which
responds to strong enhancements and reported
issues in the current wizard implementation. The
motivation for this is summarized in attached
document. A design document, plans, problems will
be added during tracking this task. The
corresponing javadoc and arch document will be
attached ASAP.

# A short issue description outlining what the
issue is and why it is being done.

Quote from
http://openide.netbeans.org/proposals/wizards/index.html#redesign
"I propose make new API based on supported
use-cases. To avoid force the changes on the
client side then the current API and its
implementation won't be changed but will be
deprecated. The new API will be separated to own
package contained API, SPI and the whole wizard's
framework."


# Target milestone
4.0

# Dependencies on other issues and issues that
depend on this one

Umbrella task 26552 depends on it (see dependency
tree at
http://www.netbeans.org/issues/showdependencytree.cgi?id=26552)

# An explanation of the change in  architecture/API.
See
http://openide.netbeans.org/proposals/wizards/index.html#general

# A list of the interfaces that the project offers
(imports) and depends on (exports).
Export API:
Wizard Manager - place for create, open and obtain
a active wizard's state, optionally close it.
Manager controls the move through wizard's
sequence, dispatches the commutation between
StepProvider, WizardHandler and WizardUI.

Export SPI:
StepProvider: Provider the wizard's steps. Can
provide next/prev step in wizard sequence, knows
the steps, knows when can wizard finish and can
validate wizard.

Step: one member in wizard's sequence and wrapper
the wizard's page. If the is marked as required
then the wizard cannot be finished before this
step passes.

Page: The central part of wizard's window. Page
provides the UI part of wizard's and controls how
to proceed the wizard's page. Page also parts in
wizard's validation. Notifies data changes to
listeners, e.g. wizard's UI to reflect it.

WizardUI: Presents UI of wizard's dialog. It's
built on list of steps and wizard page. Reflects
data changes in page (e.g. change of button's
state) and notifies the listeners about move
through wizard sequence.


# The specification (e.g. javadoc) and stability
category (aka commitment level) for each interface.

I propose deprecate current WizardDescriptor and
its subclasses and make official WizardManager,
Step, Page, StepProvider, WizardUI APIs.
Comment 1 Pavel Buzek 2003-10-15 17:17:50 UTC
The only thing I am missing is a summary of issues that depend on the
new Wizards framework. 26552 does not have any issues depending on it,
does it mean there are no dependencies or they are on subtasks?

Based on the review process this issue qualifies for the standard review:
http://openide.netbeans.org/tutorial/review-steps.html

Please complete answers for the arc questions:
http://openide.netbeans.org/tutorial/questions.html
and reassign back to me.
Comment 2 Jiri Rechtacek 2003-10-20 16:50:52 UTC
The pre-review questions are answered at
http://www.netbeans.org/source/browse/openide/arch/arch-openide-wizards.xml.
Also you can checkout openide/wizards module from wizard_36584 branch
and generate javadoc. The issue with dependences will be attached soon.
Comment 3 Jiri Rechtacek 2003-10-21 09:08:20 UTC
Issue 26552 has now the bunch of enhancements/tasks depend on this
umbrella issue. I assign back to Pavel.
Comment 4 Pavel Buzek 2003-10-29 20:45:53 UTC
reassigning to reviewers, Jarda is the owner (responsible for holding
the meeting and summarizing results), Petr J, Mila and Hrebejk are
reviewers.
I am setting 11/7 as target date. You can have the review whenever you
want (just in PRG).
Comment 5 Jaroslav Tulach 2003-11-13 12:28:58 UTC
Review document is here:
http://openide.netbeans.org/tutorial/reviews/opinions_36584.html
Comment 6 Jiri Rechtacek 2004-01-06 09:10:06 UTC
No changes planned to 3.6.
Comment 7 Jaroslav Tulach 2004-11-22 12:47:50 UTC
Making the state to match the result of the review.
Comment 8 Marian Mirilovic 2005-12-20 16:04:29 UTC
This issue was solved long time ago. Because nobody has reopened it neither
added comments, we are verifying/closing it now. 
If you are still able to reproduce the problem, please reopen. 

Thanks in advance.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo