Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 36561 - NetBeans displayed as 'runidew' in Windows Explorer's 'Open With' menu [Windows 2000 and XP]
NetBeans displayed as 'runidew' in Windows Explorer's 'Open With' menu [Windo...
Status: VERIFIED FIXED
Product: installer
Classification: Unclassified
Component: Code
3.x
PC Windows ME/2000
: P3 (vote)
: 6.x
Assigned To: issues@installer
issues@installer
:
Depends on: 20052
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-13 20:08 UTC by chrisnielsen
Modified: 2005-07-12 10:58 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments
NetBeans - FriendlyAppName Registry Entry (.REG File) (264 bytes, text/plain)
2003-10-13 20:10 UTC, chrisnielsen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description chrisnielsen 2003-10-13 20:08:37 UTC
Within Windows Explorer, when the user right-
clicks on a file associated with NetBeans (such 
as .java), and then selects the 'Open With' 
submenu, NetBeans is displayed as 'runidew' 
(rather than a friendly name like 'NetBeans 
IDE').  The same is true when the user 
selects Choose Program from the Open With 
submenu -- the resultant dialog box displays 
NetBeans as runidew.

A simple fix is to add a "friendly app name" 
entry in the Windows registry, within 
the "registered applications" area, for the 
NetBeans EXE.  The attached .REG file 
demonstrates.  [The alternative is to add Windows 
version resources, bound to the NetBeans EXE, 
with a friendly app name.  If this is done, it is 
recommended that an icon be embedded in the app 
as well -- see next paragraph.]

Note that an icon is also missing, but is (IMHO) 
less of a priority.  [Despite my best efforts, I 
cannot find any documentation regarding how one 
specifies an icon for a registered application.  
The normal Windows convention - creating 
a DefaultIcon key, with the icon file name 
stored in the default value -- does not work.  
(This technique is used when registering file 
types.)  Windows normally obtains an 
applications icon directly from the EXE, and it 
may not be possible to specify an icon for an 
application, within the registry.]
Comment 1 chrisnielsen 2003-10-13 20:10:11 UTC
Created attachment 11844 [details]
NetBeans - FriendlyAppName Registry Entry (.REG File)
Comment 2 chrisnielsen 2003-10-13 20:23:02 UTC
Vaguely related to issue #20052 ('Rename runide to something more 
memorable')
Comment 3 zikmund 2004-01-29 19:27:01 UTC
Reproducible in 3.6 with build:
NetBeansIDE-dev-200401281900-ismp5-windows.exe

I think the registry key could be changed easily (depends on wheter it
is used by NetBeans IDE ... but I think it isn't).

Renaming runidew.exe should have some consequences ... I'll
investigate it later.
Comment 4 zikmund 2004-03-03 18:07:40 UTC
Well it seems to be part of 4.0 release - I asked several developers
and managers and it is part of next release features.

Changing to ENHANCEMENT for better tracking.
Comment 5 zikmund 2004-06-03 09:56:22 UTC
Implemented in 4.0. Marking as fixed.
Comment 6 Michal Mocnak 2005-07-12 10:58:34 UTC
Verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo