Bug 36538 - main menu gets focus when switch to another window and back
main menu gets focus when switch to another window and back
Status: VERIFIED WORKSFORME
Product: platform
Classification: Unclassified
Component: Window System
3.x
PC Windows XP
: P3 (vote)
: 3.x
Assigned To: David Simonek
issues@platform
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-10 17:14 UTC by Pavel Buzek
Modified: 2008-12-22 20:37 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Buzek 2003-10-10 17:14:41 UTC
I have focus in editor and I am typing. When I
switch to e.g. netscape and back using keyboard
shortcuts (Alt+tab on winxp) the main menu gets
focus and I have to click into editor to be able
to type again. This is pretty annoying since I
loose the line where I was. Using mouse to switch
between windows (click on title of nb) works ok.
Comment 1 Peter Zavadsky 2003-10-22 14:23:53 UTC
Currently on my machine it works fine.

Which build do you use, jdk version.. and can you experience on last
build too?
Comment 2 Peter Zavadsky 2003-10-24 13:04:04 UTC
No answer, closing as worksforme... if experience on last build, reopen.
Comment 3 Pavel Buzek 2003-10-28 21:06:25 UTC
still reproducible in this config:

NetBeans dev build
------------------
Number:   031027
Date:     October 27 2003
Branding:
Branch:   winsys
Tag:

Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2-b28)
Java HotSpot(TM) Client VM (build 1.4.2-b28, mixed mode)
Comment 4 Peter Zavadsky 2003-10-29 07:52:19 UTC
Well, it seems it is windows-specific problem. On linux it works fine.
Comment 5 Peter Zavadsky 2003-10-31 13:32:19 UTC
Dafe, please could you have a look at it, you are on Windows.
Comment 6 David Simonek 2004-02-18 11:32:09 UTC
It works perfectly on 3.6 beta with windows XP, jdk 1.4.2. I believe
this was already fixed. Closing as worksforme.
Comment 7 Marian Mirilovic 2004-03-16 16:51:23 UTC
it work for me too
verified in [nb 3.6 rc1](200403141830)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo