Bug 3648 - Cannot install Bean included in BDK 1.1.
Cannot install Bean included in BDK 1.1.
Status: CLOSED FIXED
Product: guibuilder
Classification: Unclassified
Component: Code
3.x
All All
: P1 (vote)
: TBD
Assigned To: _ ttran
issues@guibuilder
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 1999-08-31 17:03 UTC by Jon Koplin
Modified: 2003-06-30 18:25 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Jar file with bad beans (1.98 KB, application/octet-stream)
2001-01-17 18:02 UTC, Marian Mirilovic
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jon Koplin 1999-08-31 17:03:07 UTC
No error message was thrown, no .jar file was added to Repository or Repository settings, nothing happened.  See juggler.jar in Attachments.

[IAN] The bug is in that the JAR requires some other JAR to be in the classpath.
I.e. we need to implement better notification of errors during beans installation

[IAN] Juggler.class includes this import:
import sunw.demo.methodtracer.MethodTracer;

and there is no class MethodTracer included in juggler.jar or in standard JDK
Comment 1 Tomas Pavek 2000-07-21 13:28:59 UTC
This report is a bit old.  The behaviour is slightly different now - at least
some excpetions like ClassNotFoundException or NoClassDefFoundError or
InstantiationException are thrown...

So I've implemented two types of checking:
- during bean installation, the bean class is tested if it can be loaded,
- when bean is added to the form, it is tested if it can be instantiated.
In both cases right exceptions are caugth and user is given a message.
Morover, class loading error is detected during creating palette items and
component palette doesn't freeze up.
Is it enough?
Comment 2 Marian Mirilovic 2001-01-17 17:42:59 UTC
verified in [nb31](34),[pilsen](010116)

BUG also appears in version : FFJ20

better step to reproduce :

- install new bean ( from attachment .jar file)
- select all beans (2)
- add to component palette

if you select palette category, you can see Error window,
and if you add bean from palette to your form you can see Error window again.
Comment 3 Marian Mirilovic 2001-01-17 18:02:59 UTC
Created attachment 473 [details]
Jar file with bad beans
Comment 4 Quality Engineering 2003-06-30 18:25:35 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo