Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 35836 - a11y: context menu in Debugger window cannot be called with keyboard
a11y: context menu in Debugger window cannot be called with keyboard
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Outline&TreeTable
3.x
Sun All
: P3 (vote)
: TBD
Assigned To: Stanislav Aubrecht
issues@platform
: A11Y
Depends on:
Blocks: 33281
  Show dependency treegraph
 
Reported: 2003-08-29 11:34 UTC by ccv
Modified: 2008-12-23 11:38 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ccv 2003-08-29 11:34:25 UTC
To reproduce:
The following popup menu appears in Debugger
Window/Breakpoints view if to click 
right mouse button  on the empty place:

New Breakpoint
Create group
Enable All
Disable All
Delete All
Paste
List Options
Properties

It is impossible  to call this menu with keyboard.

Product Version: Sun ONE Studio, Native Edition
(Build 14)
IDE Versioning:   IDE/1 spec=3.42.1  
OS: 	         SunOS version 5.8
Java; VM; Vendor = 1.4.1_02; Java HotSpot(TM)
Client VM 1.4.1_02-b06; Sun 
Microsystems Inc.
Comment 1 Maros Sandor 2004-01-07 13:11:14 UTC
This issue is probably caused by the fact that treetable views cannot 
be focused while empty. I can display the context menu by right-
clicking with mouse but pressing Shift-F10 has no effect. Assigning 
to openide for evaluation.
Comment 2 _ tboudreau 2004-01-07 20:54:12 UTC
Adding to the collection of ttv issues
Comment 3 _ tboudreau 2004-01-09 13:34:34 UTC
Milan, what is this fix-in-36 keyword you just added (and I just deleted)?

I have no plans to do further small fixes in the current TreeTableView
- there are plans to rewrite it from scratch (it is a total mess),
hopefully for Promo-D (this is up to my management), but not for 3.6.  

Convince me this particular issue (as opposed to about 50 others, some
of them much higher impact) needs to be fixed for 3.6.  Most fixes in
TreeTableView create new bugs, and other issues relating to it are
postponed to the rewrite.  If a bug is not causing a stack trace to
pop up, IMO it is not worth fixing against the current TTV codebase.

To get a sense of the magnitude of problems with TTV, see
http://www.netbeans.org/issues/showdependencytree.cgi?id=33281
Comment 4 Milan Kubec 2004-01-09 15:08:33 UTC
A11Y issues are important for being compliant with some law or
something (maybe you know beter), so I added this issue to list of
those, what would be good to fix in upcomming release.
Comment 5 _ tboudreau 2004-01-09 17:34:52 UTC
Okay, I just didn't like that someone seemed to be deciding what I was
going to fix without asking me :-)

Seriously, I want to avoid touching TTV unless something's pretty
severe.  Any changes now will just get thrown away later.
Comment 6 Stanislav Aubrecht 2005-01-17 16:05:53 UTC
when no node is selected, the popup menu is populated with actions
from the root node

Checking in src/org/openide/explorer/view/TreeView.java;
/cvs/openide/src/org/openide/explorer/view/TreeView.java,v  <-- 
TreeView.java
new revision: 1.179; previous revision: 1.178
done
Comment 7 Marian Mirilovic 2005-12-12 13:05:22 UTC
verified in NB 5.0 (200512111900)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo