Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 35617 - Background detection of unused code
Background detection of unused code
Status: RESOLVED DUPLICATE of bug 181458
Product: editor
Classification: Unclassified
Component: Hints & Annotations
3.x
All All
: P2 with 1 vote (vote)
: TBD
Assigned To: tasklist-issues@contrib
tasklist-issues@contrib
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-21 11:01 UTC by mvinar
Modified: 2015-01-02 11:03 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mvinar 2003-08-21 11:01:31 UTC
User problem:
-----------------------------------
--

User need:
-----------------------------------
As the source base gets older, the amount of code
that is not more called from anywhere grows. The
user would benefit from being notified about such
code, to maintain the quality of the codebase
high. Explicit tool that the user could invoke
would be also helpful, but the added value of
background detection is that the user does not
have to think about doing the cleanup once in a
while (many developers never do this)

Product requirement:
-----------------------------------
Background detection of unused code
Comment 1 Jan Jancura 2005-05-13 10:25:37 UTC
We can detest it for private methods / fields at least.
Comment 2 markiewb 2015-01-02 11:03:23 UTC

*** This bug has been marked as a duplicate of bug 181458 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo