Bug 35483 - OutOfMemoryError when I tried to customize Jar Build Target
OutOfMemoryError when I tried to customize Jar Build Target
Status: RESOLVED DUPLICATE of bug 35380
Product: obsolete
Classification: Unclassified
Component: jarpackager
3.x
PC Windows ME/2000
: P2 (vote)
: 3.x
Assigned To: issues@obsolete
issues@obsolete
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-19 11:04 UTC by Jan Becicka
Modified: 2003-12-11 14:22 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Full thread dumo (18.25 KB, text/plain)
2003-08-19 11:04 UTC, Jan Becicka
Details
ide.log.zip (8.93 KB, application/octet-stream)
2003-08-19 11:07 UTC, Jan Becicka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Becicka 2003-08-19 11:04:10 UTC
What I did:
I created a project from existing sources - I used
openide module source files.
I created a new jar build target and I added
Compiled Classes as a jar content.
I did "rebuild project" and then I tried to
customize my jar build target, but
OutOfMemoryError was thrown.
Comment 1 Jan Becicka 2003-08-19 11:04:55 UTC
Created attachment 11357 [details]
Full thread dumo
Comment 2 Jan Becicka 2003-08-19 11:07:02 UTC
Created attachment 11358 [details]
ide.log.zip
Comment 3 Vitezslav Stejskal 2003-08-19 13:08:16 UTC
Interesting. Unfortunately, I wasn't able to decifer where the OOME
was throw from. Honzo, does this happen regularly or was it just
random error? Ondro, any ideas?
Comment 4 Ondrej Rypacek 2003-08-19 13:26:25 UTC
Couldn't there be some relation to #35384 ? 
Comment 5 Ondrej Rypacek 2003-08-19 13:39:31 UTC
I just tried to create a new jar target and after I started the
new-from-template wizzard, the following exception popped out quite
**asynchronously**. That's the same as in #35384 and the one that
appears 24 times in this report.

Seems like that beeing the heart of both the bugs.

--------------------
java.lang.NullPointerException
	at
org.netbeans.spi.looks.Look$ListenerCache.removeListener(Look.java:675)
	at org.netbeans.spi.looks.Look.removeLookListener(Look.java:568)
	at
org.netbeans.spi.looks.ProxyLook.removeLookListener(ProxyLook.java:1166)
	at
org.netbeans.spi.looks.AccessorImpl.removeLookListener(AccessorImpl.java:36)
	at org.netbeans.api.nodes2looks.LookNode$FirerImpl.run(LookNode.java:842)
	at org.openide.util.Utilities$ActiveQueue.run(Utilities.java:2474)
[catch] at java.lang.Thread.run(Thread.java:536)
-----------------
Comment 6 Jan Becicka 2003-08-19 14:19:34 UTC
Ondra is probably right. I came across oome again, regardless of
jarpackager. NPE from Looks is reported as issue 35380.
Comment 7 Ondrej Rypacek 2003-08-19 15:12:38 UTC
Marking as duplicate of the issue mentioned above. This is clearly a
looks problem.

*** This issue has been marked as a duplicate of 35380 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo