Bug 35384 - Infinite loop in New Wizard - Jar File
Infinite loop in New Wizard - Jar File
Status: RESOLVED DUPLICATE of bug 35380
Product: obsolete
Classification: Unclassified
Component: jarpackager
3.x
PC Linux
: P1 (vote)
: TBD
Assigned To: issues@obsolete
issues@obsolete
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-12 14:16 UTC by Jan Becicka
Modified: 2003-12-11 14:10 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thred dump (13.59 KB, text/plain)
2003-08-12 14:17 UTC, Jan Becicka
Details
Stack trace (642 bytes, text/plain)
2003-08-12 14:18 UTC, Jan Becicka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Becicka 2003-08-12 14:16:51 UTC
I tried to creat a new jar build target, but I
come across infinite loop in step 4. (content
specification).

Full thread dump and exception are attached
Comment 1 Jan Becicka 2003-08-12 14:17:12 UTC
Created attachment 11281 [details]
Thred dump
Comment 2 Jan Becicka 2003-08-12 14:18:02 UTC
Created attachment 11282 [details]
Stack trace
Comment 3 Ondrej Rypacek 2003-08-18 14:04:22 UTC
I don't uderstand this report. I see a NullPointerException in looks. 
What does that "infinite loop" mean? Could you please explain this to me? 
Comment 4 Jan Becicka 2003-08-18 14:54:13 UTC
Infinite loop mean, that the IDE did a strange thing: it repeatedly
throw exceptions. This process was endless.
Comment 5 Ondrej Rypacek 2003-08-19 15:16:43 UTC
This is a looks problem -- note the exception trace. The same
exception appears often in other occasions.

JarPackager probably catalyzes the problem as it sweeps over all
source/resouce/build target descriptors and tries to acquire looks for
them. 

*** This issue has been marked as a duplicate of 35380 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo