Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 34982 - Exception when changing values of properties
Exception when changing values of properties
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Explorer
3.x
All All
: P3 (vote)
: 3.x
Assigned To: _ tboudreau
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-17 13:40 UTC by sva
Modified: 2008-12-22 23:46 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sva 2003-07-17 13:40:51 UTC
Steps to reproduce:
1. Add breakpoint to any JSP and start debugger.
2. When debugger stop on breakpoint.
3. Select some items in Local Variables window and press 
Properties context menu items.
4. Property window will appear. 
5. Place cursor on value field, type some text and press 
Enter.

Result: exception occured:

org.openide.explorer.propertysheet.ProxyNode$DifferentValues
Exception
	at 
org.openide.explorer.propertysheet.ProxyNode$ProxyProperty.g
etValue(ProxyNode.java:241)
	at 
org.openide.explorer.propertysheet.NodePropertyModel.getValu
e(NodePropertyModel.java:56)
	at 
org.openide.explorer.propertysheet.PropUtils.updateProp
(PropUtils.java:98)
	at 
org.openide.explorer.propertysheet.PropUtils.updateProp
(PropUtils.java:141)
	at 
org.openide.explorer.propertysheet.SheetCellEditor.stopCellE
diting(SheetCellEditor.java:237)
	at 
org.openide.explorer.propertysheet.SheetCellEditor.actionPer
formed(SheetCellEditor.java:150)
	at javax.swing.JTextField.fireActionPerformed
(JTextField.java:491)
	at javax.swing.JTextField.postActionEvent
(JTextField.java:672)
	at 
javax.swing.JTextField$NotifyAction.actionPerformed
(JTextField.java:786)
	at javax.swing.SwingUtilities.notifyAction
(SwingUtilities.java:1530)
	at javax.swing.JComponent.processKeyBinding
(JComponent.java:2438)
	at javax.swing.JComponent.processKeyBindings
(JComponent.java:2473)
	at javax.swing.JComponent.processKeyEvent
(JComponent.java:2401)
	at java.awt.Component.processEvent
(Component.java:4908)
	at java.awt.Container.processEvent
(Container.java:1569)
	at java.awt.Component.dispatchEventImpl
(Component.java:3614)
	at java.awt.Container.dispatchEventImpl
(Container.java:1627)
	at java.awt.Component.dispatchEvent
(Component.java:3476)
	at java.awt.KeyboardFocusManager.redispatchEvent
(KeyboardFocusManager.java:1713)
	at 
java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent
(DefaultKeyboardFocusManager.java:627)
	at 
java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent
(DefaultKeyboardFocusManager.java:831)
	at 
java.awt.DefaultKeyboardFocusManager.typeAheadAssertions
(DefaultKeyboardFocusManager.java:741)
	at 
java.awt.DefaultKeyboardFocusManager.dispatchEvent
(DefaultKeyboardFocusManager.java:592)
	at java.awt.Component.dispatchEventImpl
(Component.java:3505)
	at java.awt.Container.dispatchEventImpl
(Container.java:1627)
	at java.awt.Window.dispatchEventImpl
(Window.java:1606)
	at java.awt.Component.dispatchEvent
(Component.java:3476)
[catch] at java.awt.EventQueue.dispatchEvent
(EventQueue.java:456)
	at 
java.awt.EventDispatchThread.pumpOneEventForHierarchy
(EventDispatchThread.java:201)
	at 
java.awt.EventDispatchThread.pumpEventsForHierarchy
(EventDispatchThread.java:151)
	at java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:145)
	at java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:137)
	at java.awt.EventDispatchThread.run
(EventDispatchThread.java:100)


Reproduced with last dev build.
Comment 1 Maros Sandor 2003-07-17 15:00:21 UTC
I think the problem is in the property editor 
implementation (trying to get "old value" of multiple 
properties before changig it).
Comment 2 Marian Mirilovic 2003-07-30 07:48:13 UTC
Vladimir:
could you try it again on current dev build, it is already fixed in my
opinion, thanks in advance.
Comment 3 sva 2003-08-13 11:26:43 UTC
Sorry, cannot verify that it's not reproduced due to bug 
35410
Comment 4 _ tboudreau 2003-08-18 12:30:23 UTC
Fixed - the problem was that the original value of the 
property was being fetched for comparison with the value from
the property editor.  The DifferentValuesException is now
caught, and if present, the properties will be updated with
the new value even if it occurs.

Checking in PropUtils.java;
/cvs/openide/src/org/openide/explorer/propertysheet/PropUtils.java,v 
<--  PropUtils.java
new revision: 1.9; previous revision: 1.8
done
Comment 5 Marian Mirilovic 2005-07-13 13:25:42 UTC
closed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo