Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 34515 - Published ant-grammar.nbm needs manifest corrections to work in 3.5
Published ant-grammar.nbm needs manifest corrections to work in 3.5
Status: VERIFIED FIXED
Product: projects
Classification: Unclassified
Component: Ant
3.x
All All
: P3 (vote)
: 3.x
Assigned To: Jesse Glick
issues@projects
:
: 38106 (view as bug list)
Depends on: 38267
Blocks: 29467 33098
  Show dependency treegraph
 
Reported: 2003-06-20 18:46 UTC by Jesse Glick
Modified: 2005-07-13 13:23 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2003-06-20 18:46:58 UTC
See nbusers thread "Ant code completion module".
Check manifest in release35 sources - needs to
match impl version of XML modules in 3.5 dist.
Should be on Alpha auto update as well, not just
file download page. Should be able to run a 3.5
release binary, connect to Alpha AU, download Ant
Grammar module, and run without any other steps.
Comment 1 Jesse Glick 2003-07-04 18:34:55 UTC
Specifically, OpenIDE-Module-Module-Dependencies for the r35 version
of ant-grammar (META-INF/MANIFEST.MF in JAR, also Info/info.xml in
NBM) should read:

org.netbeans.modules.xml.core/1 = XMLr35,
org.apache.tools.ant.module/2 > 2.14
Comment 2 Jesse Glick 2003-12-19 15:17:47 UTC
Would like to have it work in 3.6; will see. Also there is a new
OIDE-M-Build-Version which should make it easier to keep a stable dep
against OIDE-M-Implementation-Version in the future.
Comment 3 Jesse Glick 2003-12-19 15:20:56 UTC
*** Issue 38106 has been marked as a duplicate of this issue. ***
Comment 4 Jesse Glick 2003-12-26 20:20:58 UTC
Hope to have this taken care of for NB 3.6.
Comment 5 Jesse Glick 2004-01-19 16:16:51 UTC
Well it should now be taken care of for NB 3.6 anyway.
Comment 6 Marian Mirilovic 2005-07-13 13:23:31 UTC
closed


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo