Bug 34296 - Focus on Editor
Focus on Editor
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Window System
3.x
PC Windows XP
: P3 (vote)
: 3.x
Assigned To: mslama
issues@platform
: FOCUS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-11 10:27 UTC by lascar
Modified: 2008-12-23 09:06 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lascar 2003-06-11 10:27:05 UTC
Every time I use the 'Find' (CTRL+F) or 'Go To
Class' (CTRL+SHIFT+O) features on the editor
window, the focus switches to the main window (in
Traditional SDI interface).
This issue, already filed for previous versions,
was not present in NetBeans IDE v3.4.1: I found it
for the first time in v3.5RC3 and in v3.5 final.
Both the 3.4.1 and 3.5 versions run on Sun JDK
1.3.1_07.
Comment 1 Marian Mirilovic 2003-06-11 11:09:41 UTC
Marek, I think this is duplicate of another issue.....
Comment 2 mslama 2003-06-16 13:53:30 UTC
I cannot reproduce. Focus is in Source Editor, press Ctrl-F, enter
some text, press Enter -> focus is back in source editor.

SDI, Linux, RH 7.1, KDE 2.1.1, JDK 1.4.2_b26 or JDK 1.3.1_08, current
NB dev build and NB 3.5 FCS.

Marian please can you check on Windows? Could be specific only to Win XP?
Comment 3 mslama 2003-06-16 14:01:36 UTC
Sorry. Misunderstanding. But anyway I cannot reproduce it: When I
invoke Ctrl-F focus is in text field of dialog.
(One additional thing: Current dev build runs only on JDK 1.4.)
Comment 4 mslama 2003-06-18 17:26:19 UTC
I checked current dev build 200306180100 on JDK 1.4.2_b26 and it
happens (sometimes, not always). I will investigate. But it happens in
MDI.
Comment 5 mslama 2003-06-25 14:32:40 UTC
This was caused by hack to fix JDK bug #4524015. (It generated
WINDOW_ACTIVATED event when Find dialog was invoked by Ctrl-F ->
requestFocus() on editor is called in such case.) Not completely clear
why this hapenned. Anyway this JDK bug was already fixed in JDK
1.3.1_03 (see #4503980) and as we support running NB on JDK 1.4 I
removed this hack -> it fixes this problem.

Fixed in main trunk.

Modified:
core/windows/src/org/netbeans/core/windows/MainWindow.java r.1.3

Removed:
core/windows/src/org/netbeans/core/windows/JdkBug4524015Hack.java
Comment 6 Marian Mirilovic 2003-07-28 13:29:52 UTC
It seems like it works fine now, verified in [nb_dev](20030728)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo